浙大 数据结构 11-散列2 Hashing【Java实现】

11-散列2 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10
​4
​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

思路:
1.其实这道题不需要真正的放到hashtable里,记录应该放的位置,输出即可;
2.二次探测存在即使有空的位置,但是也找不到地方放的情况,如果size=4K+3(k为正整数)就不会出现这种情况,但是此题的size是最小素数,所以要判断如果没有找到位置放的话何时结束二次探测。推了一下当探测次数大于size的时候就可以不继续探测了;

import java.util.Scanner;

public class Main {
	public static int[] print;
	public static boolean[] table;

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		int MSize=sc.nextInt();
		int N=sc.nextInt();
		print=new int[N];
		int size=NextPrime(MSize);
		table=new boolean[size];
		for(int i=0;i<N;i++) {
			int tmp=sc.nextInt();
			print[i]=Find(tmp,size);
		}
		int print_count=0;
		for(int i=0;i<print.length;i++) {
			if(print_count==0) {
				if(print[i]==-1) {
					System.out.print("-");
				}else {
					System.out.print(print[i]);
				}
			}else {
				if(print[i]==-1) {
					System.out.print(" "+"-");
				}else {
					System.out.print(" "+print[i]);
				}
			}
			print_count++;
		}

	}
	
	public static int NextPrime(int MSize) {
		int i;
		if(MSize==1) {
			return 2;
		}else {
			for(i=MSize;i>0;i++) {
				int flag=0;
				for(int j=2;j<=i/2;j++) {
					if(i%j==0) {
						flag=1;
						break;
					}
				}
				if(flag==0) {
					break;
				}
			}
		}
		return i;
	}
	
	public static int Hash(int key,int size) {
		return key%size;
	}
	
	public static int Find(int key,int size) {
		int count=0;
		int Newpos;
		int pos=Hash(key,size);
		if(table[pos]==false) {
			table[pos]=true;
			return pos;
		}else if(table[pos]==true) {
			count++;
			while(count<=size) {
				Newpos=(pos+count*count)%size;
				if(table[Newpos]==false) {
					table[Newpos]=true;
					return Newpos;
				}
				count++;
			}
			if(count>size) {
				return -1;
			}
		}
		return pos;
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值