1002 A+B for Polynomials(多项式的加法)

1002 A+B for Polynomials (25分)
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN1 … NK aNK

where K is the number of nonzero terms in the polynomial, Ni
​​ and a​Ni(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

PS:可能会造成阅读障碍的单词(读懂题意才能把题做对呀):
————————————————————————————————————
polynomials n. 多项式
exponent n. 幂,指数
coefficient n. 系数
decimal adj. 小数的

————————————————————————————————————
题意大致为,多项式的加法,输出第一个数k为项数,一项有一对——Nk和aNk
N·k表示的是x的Nk次方项,对应的aNk是它的系数,如Nk=2, aNk=3, 表示的是3X2
两项相加后打印在一行。

#include<iostream>
using namespace std;
const int maxn = 1010;
int main(void)
{
	int k,temp,count=0;
	double exponent[maxn] = {0};//初始化为0.0
	double coefficient;
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		cin >> temp >> coefficient;
		exponent[temp] += coefficient;
	}
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		cin >> temp >> coefficient;
		exponent[temp] += coefficient;
	}
	for (int i = 0; i < maxn; i++)
	{
		if (exponent[i] != 0)
			count++;
	}
	cout << count;
	for (int i =maxn-1; i >=0; i--)//输出
	{
		if(exponent[i] != 0)
		printf(" %d %.1f",i,exponent[i]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值