fsevents包npm install安装时报错

fsevents包npm install安装时报错

问题:

使用typescript-library-starter初始化项目时,执行npm install时,在安装fsevents@1.2.9包时出现报错,导致项目初始化失败

在网上搜了一下解决方法,有的说是node版本原因导致的,尝试切换node版本后发现并未解决,后来就试了一下清除npm缓存再重新安装的方法,最终有效的解决了fsevents@1.2.9安装报错问题

解决方法:

// 1、清除npm缓存(由于是在Mac系统下,执行npm cache clean --force命令时前面需要加sudo获取权限)
sudo npm cache clean --force
// 2、删除node_modules文件(也可手动删除node_modules文件夹)
rm -rf node_modules
// 3、重新执行安装
sudo npm install
相关推荐
©️2020 CSDN 皮肤主题: 终极编程指南 设计师:CSDN官方博客 返回首页