POJ 3278(Catch That Cow)

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 68998 Accepted: 21707

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

这是一题非常简单的入门BFS题,BFS是宽度优先搜索算法(又称广度优先搜索);
想入门一定要搞懂这题:
要有耐心,我也用了不少时间:
BFS要用到队列,这个知识要必须学会才能更好理解BFS:
代码如下:

#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
#include <queue>  
using namespace std;  

int n,s,e;  
int ss[300000],vis[300000];  

struct node  
{  
    int x;
    int step;  
};  


int BFS()  
{  
    queue<node> Q;  
    node a,next;  
    int i;  
    a.x = s;  
    a.step = 0;  
    vis[s] = 1;  
    Q.push(a);  
    while(!Q.empty())  
    {  
           a = Q.front();  
           Q.pop();  
           if(a.x == e)
           {
             return a.step; 
           }
           next = a;  
           next.x=next.x-1; 
           if(next.x>=0&&vis[next.x]==0)
           {
            vis[next.x] = 1;  
            next.step++;  
            Q.push(next);  
            }
           next = a;  
           next.x=next.x+1; 
           if(next.x<=100000&&vis[next.x]==0)
           {
            vis[next.x] = 1;  
            next.step++;  
            Q.push(next);  
            }
            next = a;  
           next.x=2*next.x; 
           if(next.x<=100000&&vis[next.x]==0)
           {
            vis[next.x] = 1;  
            next.step++;  
            Q.push(next);  
            }
    }  
    return -1;  
}  

int main()  
{  
        int i,j;  
        scanf("%d %d",&s,&e);  
        memset(vis,0,sizeof(vis));  
        printf("%d\n",BFS());   

    return 0;  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值