Turn the corner

Turn the corner

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2449    Accepted Submission(s): 933


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?

 

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.
 

Sample Input
  
  
10 6 13.5 4 10 6 14.5 4
 

Sample Output
  
  
yes no
 

上图为网上下载;
题目大意:已知汽车的长l和宽w,以及两条垂直相交的路宽为x和y,汽车所处道路宽为x ,问汽车能否成功转弯?
#include<iostream>
#include<cmath>
#define pi 3.141592653
using namespace std;
double a,s,x,w,l,h;
double cha(double a){
    s=l*cos(a)+w*sin(a)-x;
    h=s*tan(a)+w*cos(a);
    return h;
}
double Sansearch(double left,double right){
	double mid,midmid;
	while(right-left>1e-8)
        {
            mid=(left+right)/2;
            midmid=(mid+right)/2;
            if(cha(mid)>=cha(midmid))
			right= midmid;
            else left=mid;
        }
        return mid;
}
int main()
{
    double s,y;
    while(cin>>x>>y>>l>>w)
    {
        s=Sansearch(0,pi/2);
        if(cha(s)<=y)cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值