Substring(最长回文串)


You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

Input

The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').

Output

Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input

Sample Input

3                   
ABCABA
XYZ
XCVCX

Sample Output

ABA
X
XCVCX

AC代码:

#include<bits/stdc++.h>
using namespace std;
string s,ss;
int i,j,k,l;
int N;
int dp[55][55];
void sss(){
	ss="";
	for(i=s.size();i>-1;i--){
		ss+=s[i];
	}	
}
int main()
{
	while(cin>>N){
		while(N--){
			cin>>s;
			memset(dp,0,sizeof(dp));
		    sss();
			k=l=0;
			for(i=1;i<=s.size();i++)
            for(j=1;j<=ss.size();j++){
                if(s[i-1]==ss[j-1]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                if(l<dp[i][j]){
                    l=dp[i][j];  //更新 
                    k=i-1;
                }
            }
            for(i=k-l+1;i<=k;i++)
			cout<<s[i];
			cout<<endl; 
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值