You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.
Input
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
Output
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
Sample Input
3 ABCABA XYZ XCVCX
Sample Output
ABA X XCVCX
AC代码:
#include<bits/stdc++.h>
using namespace std;
string s,ss;
int i,j,k,l;
int N;
int dp[55][55];
void sss(){
ss="";
for(i=s.size();i>-1;i--){
ss+=s[i];
}
}
int main()
{
while(cin>>N){
while(N--){
cin>>s;
memset(dp,0,sizeof(dp));
sss();
k=l=0;
for(i=1;i<=s.size();i++)
for(j=1;j<=ss.size();j++){
if(s[i-1]==ss[j-1]){
dp[i][j]=dp[i-1][j-1]+1;
}
if(l<dp[i][j]){
l=dp[i][j]; //更新
k=i-1;
}
}
for(i=k-l+1;i<=k;i++)
cout<<s[i];
cout<<endl;
}
}
return 0;
}