HrbustOJ.1967.A Math Puzzle

A Math Puzzle
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 1022(548 users)Total Accepted: 579(519 users)Rating:Special Judge: No
Description

Given a duodecimal number A, then translate it into decimal number B, can you judge if B MOD 11 equals 0?

Input

There are multiple test cases. Each test case has one duodecimal number A (contain “0123456789AB”).

(The length of A <= 20)

Output

For each case, if B MOD 11 equals 0, output “YES”. Otherwise, output “NO”.

Sample Input
1
2
3
4
5
6
7
8
9
A
B
1B
Sample Output
NO
NO
NO
NO
NO
NO
NO
NO
NO
NO
YES
NO
Hint
duodecimal(十二进制)

考点:进制转换+取模运算

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
    string A;
    while(cin>>A){
        int len=A.length();
        int sum=0;
        for(int i=0; i<n; i++){
            if(A[i]=='A'){
                sum=sum*12+10;
            }else if(X[i]=='B'){
                sum=sum*12+11;
            }else{
                sum=sum*12+X[i]-'0';
            }if(sum>=11){
                sum%=11;
            }
        }
        if(sum==0)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值