ABC047&ARC063.1D Reversi

问题 E: 1D Reversi

时间限制: 1 Sec   内存限制: 128 MB
提交: 332   解决: 139
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

Two foxes Jiro and Saburo are playing a game called 1D Reversi. This game is played on a board, using black and white stones. On the board, stones are placed in a row, and each player places a new stone to either end of the row. Similarly to the original game of Reversi, when a white stone is placed, all black stones between the new white stone and another white stone, turn into white stones, and vice versa.
In the middle of a game, something came up and Saburo has to leave the game. The state of the board at this point is described by a string S. There are |S| (the length of S) stones on the board, and each character in S represents the color of the i-th (1≤i≤|S|) stone from the left. If the i-th character in S is B, it means that the color of the corresponding stone on the board is black. Similarly, if the i-th character in S is W, it means that the color of the corresponding stone is white.
Jiro wants all stones on the board to be of the same color. For this purpose, he will place new stones on the board according to the rules. Find the minimum number of new stones that he needs to place.

Constraints
1≤|S|≤105
Each character in S is B or W.

输入

The input is given from Standard Input in the following format:
S

输出

Print the minimum number of new stones that Jiro needs to place for his purpose.

样例输入

BBBWW

样例输出

1

提示

By placing a new black stone to the right end of the row of stones, all white stones will become black. Also, by placing a new white stone to the left end of the row of stones, all black stones will become white.
In either way, Jiro's purpose can be achieved by placing one stone.

[ 提交][ 状态]

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    string s;
    while(cin>>s){
        int len=s.size();
        int cnt=0,cnt1=0;
        for(int i=0;i<len-1;i++){
            if(s[i]==s[i+1]) cnt++;
            if(s[i]!=s[i+1]) {
                cnt1++;
            }
        }
        if(cnt==(len-1)) cout<<0<<endl;
        else cout<<cnt1<<endl;
    }
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值