hdu 1394 Minimum Inversion Number (线段树)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15387    Accepted Submission(s): 9387


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

 

Output
For each case, output the minimum inversion number on a single line.
 

 

Sample Input
10
1 3 6 9 0 8 5 7 4 2
 

 

Sample Output
16

 

单点更新,区间求和。查询与更新同步,每更新一个数,求比它大的数的和,即为新增的逆序数。时间复杂度为NlogN。

最后穷举每个数作为第一个元素出现时数列的逆序数,求出最小值即可,可以很容易推出,每次更换头数字的时候,新的逆序数为(原逆序数)减去(该数数值)加上(总数字减去该数数值减一)。

 

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int N = 5555;

int num[N << 2];
int hehe[N];

void Add(int i){
    num[i] = num[i * 2] + num[i * 2 + 1];    //更新父亲节点
}

void Build(int left, int right, int i){    //建树
    num[i] = 0;
    if(left == right) return;
    int mid = (left + right) / 2;
    Build(left, mid, i * 2);
    Build(mid + 1, right, i * 2 + 1);    
}
 
void Update(int number, int left, int right, int i){    //更新结点
    if(left == right){
        num[i]++;
        return;
    }
    int mid;
    mid = (left + right) / 2;
    if(number <= mid) Update(number, left, mid, i * 2);
    else Update(number, mid + 1, right, i * 2 + 1);
    Add(i);
}

int Query(int ll, int rr, int left, int right, int i){    //区间查询和
    if(ll <= left && rr >= right) return num[i];
    int mid;
    mid = (left + right) / 2;
    int haha = 0;
    if(ll <= mid) haha += Query(ll, rr, left, mid, i * 2);
    if(rr > mid) haha += Query(ll, rr, mid + 1, right, i * 2 + 1);
    return haha;
}

int main(){
    int n;
    while(~scanf("%d", &n)){
        Build(0, n - 1, 1);
        int i, sum = 0;
        for(i = 0; i < n; i++){
            scanf("%d", &hehe[i]);
            sum += Query(hehe[i], n - 1, 0 , n - 1, 1);
            Update(hehe[i], 0, n - 1, 1);
        }
        int hoho = sum;
        for(i = 0; i < n; i++){
            sum += n - 2 * hehe[i] - 1;    //推导出的逆序数穷举公式
            hoho = min(sum, hoho); 
        }
        printf("%d\n", hoho);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Cyy666/p/4969227.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值