hdu 5563 Clarke and five-pointed star (水题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 351    Accepted Submission(s): 197

 

 

Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a learner of geometric. 
When he did a research with polygons, he found he has to judge if the polygon is a five-pointed star at many times. There are 5 points on a plane, he wants to know if a five-pointed star existed with 5 points given.
 


Input
The first line contains an integer  T(1T10), the number of the test cases. 
For each test case, 5 lines follow. Each line contains 2 real numbers xi,yi(109xi,yi109), denoting the coordinate of this point.
 


Output
Two numbers are equal if and only if the difference between them is less than  104
For each test case, print Yes if they can compose a five-pointed star. Otherwise, print No. (If 5 points are the same, print Yes. )
 


Sample Input
2 3.0000000 0.0000000
0.9270509 2.8531695
0.9270509 -2.8531695
-2.4270509 1.7633557
-2.4270509 -1.7633557
3.0000000 1.0000000
0.9270509 2.8531695
0.9270509 -2.8531695
-2.4270509 1.7633557
-2.4270509 -1.7633557
 


Sample Output
Yes No
 
 
 
 
 
 
遍历五个点,找到与当前点最远的点,求出距离。可以求得五个距离,如果这五个距离相等,则可以组成一个正五角星。
 
 

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#define PI acos(-1)

int cmp(const void *a, const void *b){
  return *(double *)a > *(double *)b ? 1 : -1;
}
int main(){
  int T;
  scanf("%d", &T);
  while(T--){
    double x[5], y[5];
    int i, j;
    int count = 0;
    double hehe, hoho;
    for(i = 0; i < 5; i++) scanf("%lf%lf", &x[i], &y[i]); //保存下五个点的数据
    for(i = 0; i < 5; i++){
      double dis[5]; //操作当前点
      for(j = 0; j < 5; j++){
        dis[j] = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));
      }
    qsort(dis, 5, sizeof(double), cmp); //排序找到距离当前点最远的点
    double dismax;
    dismax = dis[4];
    if(count == 0) hehe = dismax;
    if(-0.0001 < hehe - dismax && hehe - dismax < 0.0001) count++;
    hehe = dismax;
    }

    if(count == 5) printf("Yes\n"); //五条边相等
    else printf("No\n");
  }
  return 0;
}

转载于:https://www.cnblogs.com/Cyy666/p/4969018.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值