ZOJ1610-Count the Colors

本文探讨了一种优化算法,通过使用线段树技术解决在区间内进行颜色更新并计数可见颜色种类的问题。详细介绍了两种方法,一种为传统数组标记法,另一种为线段树优化法。重点分析了线段树方法如何避免不必要的递归深入,显著提升性能。
摘要由CSDN通过智能技术生成
Count the Colors

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

 

题目大意:在一段0-8000的区间上面涂色(0-8000种之多),后涂上去的颜色将覆盖前面的颜色,问最后能够看见的颜色的种类和片段数量!

思路:很明显,用数组标记即可,代码如下

 

#include<stdio.h>
#include<string.h>
int a[8000]={0},b[8000]={0},c[8000];
int main()
{
    int n,i,j,count,k;
    memset(a,0,sizeof(a));
    while(scanf("%d",&n)!=EOF)
    {    
        for(i=n-1;i>=1;i--)
     {
      scanf("%d",&a[i]);
      a[i]++;
     }
     a[n]++;
        for(i=1;i<=n;i++)
            b[i]=i;
        for(i=1,k=n;i<=n;i++)
        {
            for(j=1,count=0;;j++)
      {
                if(b[j]!=0) 
       {
        count++;  
        if(a[i]==count) break;
       }
      }
            c[k--]=b[j];
            b[j]=0;
        }
        for(i=1;i<=n;i++)
            printf("%d\n",c[i]);
    }
    system("pause");
    return 0;
}
但是最近几天在学习线段树,于是硬着头皮写,进过一天的奋战,终于写出来了,如下,但是很悲剧,超时了!
仔细分析与研究别人的代码,发现基本思路相同,但是有一个重要的不同之处
就是:染色和更新能不往下走的时候绝对不往下走到叶子结点,而是一旦匹配就返回,遇到非得往下更新的时候,也只是更新一部分,另一部分不用更新的也返回!而我的是每次基本上都处理到叶子结点,这就大大的超时了!
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 8000
int flag;
int num[N+1]={0};
struct intervaltree
{
    int l,r,cover;
    struct intervaltree *lchild,*rchild;
};
void initial(struct intervaltree *T)//可以不要了,建树和统计的时候就会将其初始化了 
{
    if(T==NULL) return ;
    T->cover=-1;
    initial(T->lchild);
    initial(T->rchild);
}
struct intervaltree *tcreat(struct intervaltree *T,int left,int right)
{
    T=(struct intervaltree *)malloc(sizeof(struct intervaltree));
    T->l=left;
    T->r=right;
    T->cover=-1;
    if(right-left==1) 
    {
        T->lchild=T->rchild=NULL;
        return T;
    }
    T->lchild=tcreat(T->lchild,left,(left+right)/2);
    T->rchild=tcreat(T->rchild,(left+right)/2,right);
 return T;
}
void coverleave(struct intervaltree *T,int color)
{
 if(T==NULL) return ;
 T->cover=color;
 coverleave(T->lchild,color);
 coverleave(T->rchild,color);
}
void changcolor(struct intervaltree *T,int a,int b,int color)
{
    int mid;
 if(T->cover==color) return ;//如果已经涂了形同的颜色了,就不再深入里面了
    if(a<=T->l&&T->r<=b)
    {
        //T->cover=color;
  //if(T->lchild!=NULL)
  coverleave(T,color);//如果染色的不是叶子结点,则把他的孩子全部染成同样的颜色
        return ;
    }
    mid=(T->l+T->r)/2;
    if(b<=mid) 
        changcolor(T->lchild,a,b,color);
    else if(a>=mid) 
        changcolor(T->rchild,a,b,color);
    else
    {
        changcolor(T->lchild,a,mid,color);
        changcolor(T->rchild,mid,b,color);
    }
    if(T->lchild!=NULL)//如果有孩子,则看颜色能不能合并 
    {
        if((T->lchild->cover==T->rchild->cover)&&(T->lchild->cover)!=-1)
            T->cover=T->lchild->cover;
        else T->cover=-1;
    }
}
void statistic(struct intervaltree *T)
{
    if(T==NULL) return ;
    if(T->cover!=-1)
    {
        if(flag!=T->cover)
        {
            num[T->cover]++;
            flag=T->cover;            
        }
        coverleave(T,-1);//统计过后将颜色檫除 
        return ;
    }
 if(T->lchild==NULL)//遍历到非空未涂色结点,则说明上一次的统计已经被隔开,和下一次统计不再是相邻的区间了
 {
  flag=-1;
  return ;
 }
    statistic(T->lchild);
    statistic(T->rchild);
}
int main()
{
    int n,i,start,end,color;
    struct intervaltree *T;
    T=tcreat(T,0,N);
    while(scanf("%d",&n)!=EOF)
    {
  //initial(T);
        for(i=0;i<n;i++)
        {
            scanf("%d %d %d",&start,&end,&color);
            changcolor(T,start,end,color);
        }
        flag=-1;
        statistic(T);
        for(i=0;i<=N;i++)
            if(num[i]!=0) 
   {
    printf("%d %d\n",i,num[i]);
    num[i]=0;
   }
        printf("\n");
    }
    return 0;
} 
下面是我最后AC的代码,实在是花了好长的时间写出来的啊!
#include<stdio.h>
#define N 8010
int num[N]={0};
struct node
{
    int l,r;//存储区间 
    int cover;//涂色状态,-1表示未完全涂色 ,-2表示未涂色,>=0时表示结点及其子节点的颜色 
}tree[N*3];
void Tbuild(int p,int left,int right)
{
    int mid,v;
    tree[p].l=left;
    tree[p].r=right;
    tree[p].cover=-2;
    if(left+1==right) 
        return ;
    mid=(left+right)>>1;
    v=p<<1;
    Tbuild(v,left,mid);
    Tbuild(v+1,mid,right);
}
void insert(int p,int start,int end,int color)
{
    int v,mid;
    if(tree[p].l==start&&tree[p].r==end||tree[p].cover==color)
    {//刚好匹配或者要涂得颜色与原来已经有的颜色相同
        tree[p].cover=color;
        return ;
    }
 v=p<<1;
 if(tree[p].cover>=0)//插入的时候,如果当前结点有颜色,但是要插入的新
 {//的颜色区间小于当前区间的时候,则将当前区间的信息传递下去
  tree[v].cover=tree[p].cover;
  tree[v+1].cover=tree[p].cover; 
 }
 tree[p].cover=-1;//要涂色的区间在里面,将本区间标记为部分染色
    mid=(tree[p].l+tree[p].r)>>1;
    if(end<=mid)
    {
        insert(v,start,end,color);
    }
    else if(start>=mid)
    {
        insert(v+1,start,end,color);
    }
    else 
    {
        insert(v,start,mid,color);
        insert(v+1,mid,end,color);
    }
}
void statistic(int p)
{
    int v;
    if(tree[p].cover==-2) 
        return;    
    else if(tree[p].cover>=0)
    {
        if(tree[0].cover!=tree[p].cover||tree[p].l!=tree[0].r)//两次统计的颜色不同或者颜色相同但是不相邻 
            num[tree[p].cover]++;
        tree[0]=tree[p];
        //tree[p].cover=-2;//本来想着统计的时候初始化树的,结果发现不能够做到,所以不要了,干脆每次重新建树吧
        return ;
    }
    else
    {
        v=p<<1;
        statistic(v);
        statistic(v+1);
    }
}    
int main()
{
    int n,i,start,end,color;
    while(scanf("%d",&n)!=EOF)
    {
        Tbuild(1,0,N); 
  for(i=1;i<=n;i++)
        {
            scanf("%d %d %d",&start,&end,&color);
            insert(1,start,end,color);
        }
        tree[0].l=tree[0].r=tree[0].cover=-1;//利用tree[0]存放上一次统计到的信息  
        statistic(1);
        for(i=0;i<=N;i++)
            if(num[i]>0)
            {
                printf("%d %d\n",i,num[i]);
                num[i]=0;
            }
        printf("\n");
    }
    return 0;
}/*
测试数据
2
0 1 0
2 3 0
5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
0 21 1
2 1
3 1
1 1
0 2
1 1
*/
        

 
 
 
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值