HDU1018-Big Number(阶乘的位数)

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19970    Accepted Submission(s): 8969


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

/*直接计算阶乘,实际上是不可行的,因为数太大 #include<stdio.h> #include<string.h> #define LEN 10000000 int a[LEN]; int main(){     int i,sum,j,c,N,n,max;     scanf("%d",&N);     while(N--){         scanf("%d",&n);         memset(a,0,sizeof(a));         a[0]=max=1;         for(i=2;i<=n;i++)             for(j=0,sum=c=0;j<LEN;j++){                 sum=c+a[j]*i;                 a[j]=sum%10;                 c=sum/10;             }         for(i=LEN-1;i>=0&&a[i]==0;i--);         printf("%d\n",i+1);     }              system("pause");     return 0; } */

方法二:我们知道,任何一个数的位数=(int)log10(n)+1,而n!=1*2*3*4...*n,所以,我们对两边取对数,就变成n!的位数m=(int((log10(1)+log10(2)+...log10(n))+1,用循环求出即可!代码:
/* 取对数计算法 
#include<stdio.h>
#include<math.h>
int main(){
    int i,n,x;
    double sum;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&x);
        sum=0;
        while(x>=1){
            sum+=log10(x);
            x--;
        }
        sum=floor(sum);
        printf("%.0lf\n",sum+1); 
    } 
    return 0;
} 
*/
方法三:利用斯特林公式计算。斯特林公式如图:
代码:
#include<stdio.h>
#include<math.h>
#define PI 3.1415926
int main(){
    int i,n,x,sum;
    scanf("%d",&x);
    while(x--){
        scanf("%d",&n);
        sum=(int)((n*log(n)-n+0.5*log(2*PI*n))/log(10))+1;
        printf("%d\n",sum);
    } 
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值