HDU1517-A Multiplication Game

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2418    Accepted Submission(s): 1385


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 
 
题目大概意思是:两人轮流乘一个2-9的数,从1开始乘,求谁的乘积先大于N。

    如果是加法就好做了。凑到剩下的数能整除11,然后对称着加。问题是乘法。

    所以寻找必胜点(段)。以1000为例。

    1000 | 999 ... 112 |    若占住999到112,则对手必胜。所以,要想胜就必须让对手占领此段。

    1000 | 999 ... 112 | 111 ... 56 |   因此必占段是 111 -? 。如果56被对手占住,则56×2=112,入必败段。问题转化成为占56。

    如此循环。如下 1000 | 999 ... 112 | 111 ... 56 | 55 ... 7 | 6 ... 4 | 3 ... 1

代码:

#include<stdio.h>
int main() {
    int n,i,step;
    while(scanf("%d",&n)!=EOF) {
        if(n==1){
            printf("Stan wins.\n");
            continue;
        }
        step=0;
        while(n>1) {
            step++;//step为奇数时,【n-1,(n+8)/9】求的是要让对手进入的区间 
            if(step%2==1)
                n=(n+8)/9;
            else //step为偶数时,【n-1,(n+1)/2】求的是自己需要进入的区间 
                n=(n+1)/2;
        }
        if(step%2==1)
            printf("Stan wins.\n");
        else 
            printf("Ollie wins.\n");       
    }
    system("pause");
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值