HDU1018-求阶乘的位数

题目

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42987    Accepted Submission(s): 21003


 

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

 

 

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

 

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

 

 

Sample Input

 

2 10 20

 

 

Sample Output

 

7 19

 

 

Source

Asia 2002, Dhaka (Bengal)

大意是给一个整数,求其阶乘是多少位数,发现使用大数类直接求解超时,搜索了博客之后get到了新技能点,如下

要求一个数的位数,如147324:由int(log10(147324))= 5,可知147324的位数为int(log10(147324))+1,对于数字n的阶乘,有    double类型→log10(1*2*3*……*n)= log10(1)+log10(2)+……+log10(n)即其位数 = int类型→log10(1)+log10(2)+……+log10(n)+1,累加即可。

 

贴代码

 

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int t,n;
    while(cin >> t)
    {
        while(t--){
            cin >> n;
            double ans = 0;
            for(int i = 1; i <= n; i++)
            {
                ans += log10(i);
            }
            cout << (int)ans + 1 <<endl;
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值