Godfather POJ - 3107

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input
6
1 2
2 3
2 5
3 4
3 6
Sample Output
2 3
网传都是dp。。。- -!
我怎么感觉这不是个dp呢
首先处理一下这个图,从任意一点,开始向着一个方向深入,求出每一个子树的子节点数
假设某一个节点的子树有n个,那么这个点就把图分成了n+1个子树,其中的1是父亲节点的树。
注意 STL超时,我试过了,前向星能过
STL果断超时了
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int M = 50000+10;
vector<int>edge[M];
int tol[M],n;
int ans[M],sans[M];
int minn;
int culson(int son,int f)
{
    tol[son]=1;
    int len=edge[son].size();
    for(int i=0;i<len;i++)
    {
        int v=edge[son][i];
        if(v!=f)
        {
            tol[son]+=culson(v,son);
        }
    }
    return tol[son];
}
void update(int son,int f)
{
    ans[son]=0;
    int len=edge[son].size();
    for(int i=0;i<len;i++)
    {
        int v=edge[son][i];
        if(v!=f)
        {
            ans[son]=max(ans[son],tol[v]);
            update(v,son);
        }
    }
    ans[son]=max(ans[son],n-tol[son]);
    minn=min(ans[son],minn);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        minn=0x3f3f3f3f;
        int u,v;
        for(int i=1; i<=n; i++)
            tol[i]=0;
        for(int i=0;i<n-1;i++)
        {
                    scanf("%d%d",&u,&v);
        edge[u].push_back(v);
        edge[v].push_back(u);
        }
        culson(1,1);
        update(1,1);
        int c=0;
        for(int i=1;i<=n;i++)
        {
            if(ans[i]==minn)
            {
                sans[c++]=i;
            }
        }
        for(int i=0;i<c;i++)
        {
            if(i==c-1)
                printf("%d\n",sans[i]);
            else
                printf("%d ",sans[i]);
        }
    }
}
前向星:
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int M = 50000+10;
int tol[M],n,anss;
int ans[M],sans[M];
int pre[M];
int minn;
struct aa
{
    int v,next;
} edge[5*M];
void add(int u,int v)
{
    edge[anss].v=v;
    edge[anss].next=pre[u];
    pre[u]=anss++;
}
int culson(int son,int f)
{
    tol[son]=1;
    for(int i=pre[son]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v!=f)
        {
            tol[son]+=culson(v,son);
        }
    }
    return tol[son];
}
void update(int son,int f)
{
    ans[son]=0;
    for(int i=pre[son]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v!=f)
        {
            ans[son]=max(ans[son],tol[v]);
            update(v,son);
        }
    }
    ans[son]=max(ans[son],n-tol[son]);
    minn=min(ans[son],minn);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        minn=0x3f3f3f3f;
        anss=0;
        int u,v;
        for(int i=1; i<=n; i++)
        {
            tol[i]=0;
            pre[i]=-1;
        }

        for(int i=0; i<n-1; i++)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        culson(1,1);//找到以son为根,以f为父亲节点的树的成员总数
        update(1,1);//更新
        int c=0;
        for(int i=1; i<=n; i++)
        {
            if(ans[i]==minn)
            {
                sans[c++]=i;
            }
        }
        for(int i=0; i<c; i++)
        {
            if(i==c-1)
                printf("%d\n",sans[i]);
            else
                printf("%d ",sans[i]);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值