Dining POJ - 3281 思维建图+最大流

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

思路:

所有食物节点链接到超级起点,所有饮品节点连接到超级终点,之后将一只牛拆分成两只后链接(容量为1),这样保证每一只牛之取一组数据,然后套最大流模板就OK了。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=600;
struct node
{
    int u,v,next,c;
};
node edge[50000000];
int head[maxn];
int cnt;
int dis[maxn];
int n,f,d,F,ans;
int save1[maxn],save2[maxn];
void init()
{
    memset(head,-1,sizeof(head));
    cnt=0;
    memset(dis,-1,sizeof(dis));
    ans=0;
}
void add(int a,int b,int c)
{
    edge[cnt].u=a;
    edge[cnt].v=b;
    edge[cnt].c=c;
    edge[cnt].next=head[a];
    head[a]=cnt++;
}
int bfs()// 给各点分层,离源点的远近分
{
    memset(dis, -1, sizeof(dis));
    queue<int> q;
    dis[0] = 0;
    q.push(0);
    int i;
    int cur;
    while(!q.empty())
    {
        cur = q.front();
        q.pop();
        for(i = head[cur]; i != -1; i = edge[i].next)
        {
            if(dis[edge[i].v] == -1 && edge[i].c > 0)
            {
                dis[edge[i].v] = dis[cur] + 1;
                q.push(edge[i].v);
            }
        }
    }
    if(dis[F] < 0)
        return 0;
    return 1;
}
int Find(int x,int low) //找增广
{
    int a;
    if(x==F) return low;
    for(int i=head[x]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(dis[v]==dis[x]+1 && edge[i].c>0 &&(a=Find(v,min(low,edge[i].c))))
        {
            edge[i].c -=a;
            edge[i^1].c +=a;
           // printf("%d->%d\n",x,v);
            return a;
        }
    }
    return 0;
}
void dinic()
{
    int temp;
    while(bfs())
    {
        temp=Find(0,0x3f3f3f3f);
        ans+=temp;
    }
    printf("%d\n",ans);
}
int main()
{
    while(~scanf("%d%d%d",&n,&f,&d))
    {
        init();
        int fi,di,temp;
        F=f+d+2*n+1;
        for(int i=1; i<=f; i++)//食物链接超级起点
        {
            add(0,i,1);
            add(i,0,0);
        }
        for(int i=f+1; i<=f+d; i++)//饮品链接超级终点
        {
            add(i,F,1);
            add(F,i,0);
        }
        for(int i=1; i<=n; i++)//牛拆分链接
        {
            add(f+d+i,f+d+n+i,1);
            add(f+d+n+i,f+d+i,0);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&fi,&di);
            for(int j=1; j<=fi; j++)
            {
                scanf("%d",&temp);
                add(temp,f+d+i,1);
                add(f+d+i,temp,0);
            }
            for(int j=1; j<=di; j++)
            {
                scanf("%d",&temp);
                add(f+d+n+i,f+temp,1);
                add(f+temp,f+d+n+i,0);
            }
        }
        dinic();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值