Network of Schools POJ - 1236 Tarjan强连通

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.
Input
The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.
Output
Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.
Sample Input
5
2 4 3 0
4 5 0
0
0
1 0
Sample Output
1
2 
思路 问题一:问你整个图至少需要多少软件才可以传达到每个点,对于这个问题可以直接用tarjan缩点,然后统计入度,入度为0的点需要一个软件。

问题二:问你如果要让整个图联通至少需要链接多少条边,统计入度出度,满足他们的最大值就可以了。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=120;
int low[M],dfn[M],stk[M],idx,head,instk[M],cnt,belong[M],n,gra[M][M],in[M],out[M];
void trajan(int x)
{
    low[x]=dfn[x]=idx++;
    stk[++head]=x;
    instk[x]=1;
    for(int i=1; i<=n; i++)
    {
        if(!gra[x][i])
            continue;
        if(dfn[i]==-1)
        {
            trajan(i);
            low[x]=min(low[x],low[i]);
        }
        else if(instk[i])
        {
            low[x]=min(low[x],dfn[i]);
        }
    }
    if(dfn[x]==low[x])
    {
        int temp;
        ++cnt;
        while(1)
        {
            temp=stk[head--];
            belong[temp]=cnt;
            instk[temp]=0;
            if(temp==x)
                break;
        }
    }

}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(gra,0,sizeof(gra));
        memset(dfn,-1,sizeof(dfn));
        memset(instk,0,sizeof(instk));
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        cnt=0,idx=0,head=0;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                int temp;
                scanf("%d",&temp);
                if(!temp)
                    break;
                gra[i][temp]=1;
            }
        for(int i=1; i<=n; i++)
        {
            if(dfn[i]==-1)
                trajan(i);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(gra[i][j]&&belong[i]!=belong[j])
                {
                    in[belong[j]]++;
                    out[belong[i]]++;
                }
            }
        }
        int sum_in=0,sum_out=0;
        for(int i=1; i<=cnt; i++)
        {
            if(in[i]==0)
                sum_in++;
            if(out[i]==0)
                sum_out++;
        }
        if(cnt==1)
            printf("1\n0\n");
        else
            printf("%d\n%d\n",sum_in,max(sum_in,sum_out));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值