Food Delivery ZOJ - 3469 区间dp

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.


Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55

恩 没错,这道题我又看题解了,不过我感觉我已经有所突破。

这道题就是分析题。

首先如果在一个地方有个餐厅要去送餐,那么送完了一定存在两个状态,不是在区间的左边就是在区间的右边

这样的话我们已餐厅的位置为首要位置向两边扩充即可

对于dp[i][j][0]他的状态只能通过dp[i+1][j][0]转移而不能通过dp[i+1][j][1]转移而来,因为如果从右边来的话,再到左边一定遍历了左边的所求的区间,这样的话一定不是最优的,所有每一种状态对应的转移方程是一定的。

所以dp问题主要靠分析问题的本质

#include<bits/stdc++.h>
using namespace std;
int dp[1086][1086][2];
int sum[1086];
struct aa
{
    int pos;
    int val;
} sv[1086];
bool cmp(const aa &a,const aa &b)
{
    return a.pos<b.pos;
}
int main()
{
    int n,v,p,pos;
    while(scanf("%d%d%d",&n,&v,&p)!=EOF)
    {
        for(int i=1; i<=n; i++)
            scanf("%d%d",&sv[i].pos,&sv[i].val);
        sv[++n].pos=p;
        sv[n].val=0;
        memset(dp,0,sizeof(dp));
        sort(sv+1,sv+1+n,cmp);
        for(int i=1; i<=n; i++)
        {
            if(sv[i].pos==p)
            {
                pos=i;
                break;
            }
        }
        memset(dp,0x3f3f3f3f,sizeof(dp));
        sum[0]=0;
        for(int i=1; i<=n; i++)
        {
            sum[i]=sum[i-1]+sv[i].val;
        }
        dp[pos][pos][0]=dp[pos][pos][1]=0;
        for(int i = pos; i >= 1; i--)
        {
            for(int j = pos; j <= n; j++)
            {
                int delay = sum[i-1]+sum[n]-sum[j];
                if(i == j)
                    continue;
                dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][0]+(sv[i+1].pos-sv[i].pos)*(delay+sv[i].val));
                dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][1]+(sv[j].pos-sv[i].pos)*(delay+sv[i].val));
                dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][0]+(sv[j].pos-sv[i].pos)*(delay+sv[j].val));
                dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][1]+(sv[j].pos-sv[j-1].pos)*(delay+sv[j].val));
            }
        }
        printf("%d\n", min(dp[1][n][0], dp[1][n][1])*v);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值