2018 Multi-University Training Contest 1--Triangle Partition--hdu--6300

 

 

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1356    Accepted Submission(s): 682
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input

 

1 1 1 2 2 3 3 5

 

 

Sample Output

 

1 2 3

 

 

Source

2018 Multi-University Training Contest 1

题意:

就是给你一堆点,然后问你最多能组成多少个三角形.

题解:

很简单,按照点的x轴排个序就好了。

代码:

#include<bits/stdc++.h>
using namespace std;
struct tr{
    int x,y,num;
};
int cmp(tr a,tr b){
    if(a.x > b.x) {
        return false;
    } else if(a.x == b.x) {
        if(a.y > b.y) {
            return false;
        } else {
            return true;
        }
    } else {
        return true;
    }
}
int main() {
	tr a[99999];
    int _,n;
    for(scanf("%d",&_);_;_--){
        scanf("%d",&n);
        for(int i = 0; i < 3*n;i++){
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].num = i+1;
        }
        sort(a,a+(3*n),cmp);
        for(int i = 0;i < 3*n;i++){
            printf("%d ",a[i].num);
        }
        puts("");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值