最短路:HDU2377

 

Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1226    Accepted Submission(s): 529


 

Problem Description

You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:



Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!

 

 

Input

On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers idi (1 <= idi <= 9 999) and mzi (1 <= mzi <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mzi integers: the numbers of the adjacent zones.

nr lines starting with one integer mri (1 <= mri <= 20), indicating the number of zones the ith bus trip visits, followed by mri integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

 

 

 

Output

For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

 

 

 

Sample Input

 

1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416

 

 

Sample Output

 

4 7400

这题由于bus的数据范围很小,所以每个点不重复地进行一次SPFA是可以的,然后求出每个点到目的点的最大值点,其他的没什么了,但是需要特别注意的是初始化那边还有输入的城镇可能不是按照数字升序输入的,所以初始化那边把所有点都初始化一遍;以及最后找中心zone时先把id sort一下,其他没什么了...QAQ初始化那边哇了一发www

 

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <set>
#include <algorithm>
using namespace std;
const int MAXN=10001;
const int INF=0x3f3f3f3f;
vector<int> E[MAXN];
bool vis[MAXN];//在队列标志
int cnt[MAXN];//每个点的入队列次数
int dist[MAXN];
int id[MAXN];
int maxn[MAXN];
set<int> city;
set<int>::iterator it;
bool SPFA(int start,int n){
	memset(vis,false,sizeof(vis));
	for(int i=1;i<=n;i++)dist[id[i]]=INF;
	vis[start]=true;
	dist[start]=0;
	queue<int>que;
	while(!que.empty())que.pop();
		que.push(start);
		memset(cnt,0,sizeof(cnt));
		cnt[start]=1;
		while(!que.empty()){
			int u=que.front();
			que.pop();
			vis[u]=false;
			for(int i=0;i<E[u].size();i++){
				int v=E[u][i];
				if(dist[v]>dist[u]+1){
					dist[v]=dist[u]+1;
					if(!vis[v]){
						vis[v]=true;
						que.push(v);
						if(++cnt[v]>n)return false;
				}
			}
		}
	}
	return true;
}
int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		city.clear();
		memset(maxn, 0, sizeof(maxn));
		for(int i = 1; i <= MAXN; i++)
		{
			E[i].clear();
		}
		for(int i = 1; i <= n; i++)
		{
			int mz;
			scanf("%d%d", &id[i], &mz);
			while(mz--)
			{
				int v;
				scanf("%d", &v);
				E[id[i]].push_back(v);
				E[v].push_back(id[i]);
			}
		}
		for(int i = 0; i < m; i++)
		{
			int nz;
			scanf("%d", &nz);
			while(nz--)
			{
				int v;
				scanf("%d", &v);
				city.insert(v);
			}
		}
		for(it = city.begin(); it != city.end(); it++)
		{
			int s = *it;
			SPFA(s, n);
			for(int i = 1; i <= n; i++)
			{
				if(maxn[id[i]] < dist[id[i]])
				{
					maxn[id[i]] = dist[id[i]];
				}
			}
		}
		sort(id, id+n);
		int ans = INF, idd;
		for(int i = 1; i <= n; i++)
		{
			if(ans > maxn[id[i]])
			{
				ans = maxn[id[i]];
				idd = id[i];
			}
		}
		printf("%d %d\n", ans + 1, idd);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值