Balanced Number HDU - 3709(数位DP)

Balanced Number HDU - 3709

 A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y]. 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input

2
0 9
7604 24324

Sample Output

10
897
题意:

找出区间内平衡树的个数,所谓平衡数,就是以这个数字的某个位作为支点,另外两边的数字大小乘以力矩之和相等。

分析:

枚举支点,算力矩

dp[pos][x][st] d p [ p o s ] [ x ] [ s t ] 表示第pos位支点为x位,当前力矩为st的数的个数

st初始化为0,每次枚举到一位的时候计算 st=i×posx s t = i × ( p o s − x )

这样支点左边的为正右边为负,只要最终结果为0说明平衡

转移方程为 dp[pos][x][st]=dp[pos1][x][st+i×(posx)] d p [ p o s ] [ x ] [ s t ] = d p [ p o s − 1 ] [ x ] [ s t + i × ( p o s − x ) ]

注意最后要减去全是零的情况

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N = 20;
ll l,r,dp[N][N][N*101];
int T,bits[N];
ll dfs(int pos,int x,int st,bool limit){
    if(pos < 0) return !st;//如果st是0说明平衡
    if(st < 0) return 0;//如果小于0,之后一定不可能满足了,因为之后一定只能减少
    ll &dpnow = dp[pos][x][st];
    if(!limit && dpnow != -1) return dpnow;
    ll ans = 0;
    int up = limit ? bits[pos] : 9;
    for(int i = 0; i <= up; i++){//st+i*(pos-x)即位置距离乘数本身,在pivot左边是加右边是减
        ans += dfs(pos - 1, x, st + i * (pos - x), limit && i == bits[pos]);
    }
    if(!limit) dpnow = ans;
    return ans;
}
ll solve(ll x){
    if(x < 0) return 0;
    int len = 0;
    ll ans = 0;
    while(x){
        bits[len++] = x % 10;
        x /= 10;
    }
    for(int i = 0; i < len; i++){//枚举每个位置作为pivot
        ans += dfs(len-1,i,0,1);
    }
    return ans - (len-1);//减去全零的情况有几位有几次重复的,最终只需保留一种,因此要减去len-1
                        //如5-999,有三种情况0,00,000,都代表0,减去2
}
int main(){
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    while(T--){
        scanf("%lld%lld",&l,&r);
        printf("%lld\n",solve(r)-solve(l-1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值