Light oj 1140 How Many Zeroes?

Jimmy writes down the decimal representations of all natural numbers between and including m and n, (m ≤ n). How many zeroes will he write down?

Input

Input starts with an integer T (≤ 11000), denoting the number of test cases.

Each case contains two unsigned 32-bit integers m and n, (m ≤ n).

Output

For each case, print the case number and the number of zeroes written down by Jimmy.

Sample Input

5

10 11

100 200

0 500

1234567890 2345678901

0 4294967295

Sample Output

Case 1: 1

Case 2: 22

Case 3: 92

Case 4: 987654304

Case 5: 3825876150

求n-m中0的个数

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

typedef long long ll;
ll a[20];
ll dp[20][20];//第i位前面有j个0
ll dfs(ll pos,ll iszero,ll s,ll lim)//当前位置,前面是否全是0,前面0的个数,前一位是否到了最大值
{
    if(pos==-1)
    {
        if(iszero)//如果所有的数位都是0,那么该数字是0,则算一个有效0
            return 1;
        else
            return s;
    }
    if(!lim&&dp[pos][s]!=-1&&!iszero)
        return dp[pos][s];
    int up=lim?a[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        if(iszero)
            ans+=dfs(pos-1,i==0,0,lim&&i==up);//如果前面全是0,判段当前位置是不是0
        else
            ans+=dfs(pos-1,0,s+(i==0),lim&&i==up);//如果前面不全是0,如果i是0那么此时的0是一个有效0
    }
    if(!lim&&!iszero)
        dp[pos][s]=ans;
    return ans;
}
ll solve(ll n)
{
    int i=0;
    while(n)
    {
        a[i++]=n%10;
        n/=10;
    }
    return dfs(i-1,1,0,1);
}
int main()
{
    int t;
    scanf("%d",&t);
    int kase=1;
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        ll n,m;
        scanf("%lld%lld",&n,&m);
        printf("Case %d: ",kase++);
        printf("%lld\n",solve(m)-solve(n-1));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值