HDU 4576 Robot(概率dp)

19 篇文章 0 订阅

Robot

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 2370    Accepted Submission(s): 835


Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 

Sample Input
  
  
3 1 1 2 1 5 2 4 4 1 2 0 0 0 0
 

Sample Output
  
  
0.5000 0.2500

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;
//author:YangSir
//time:2014/6/23
int main()
{
	double dp[2][250],ans;//状态只有2个,要么顺时针,要么逆时针
	int i,n,m,l,r,w;
	int q,h,f;
	while(~scanf("%d%d%d%d",&n,&m,&l,&r),(m+n+l+r)){
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		f=0;
		ans=0;
		while(m--){
			scanf("%d",&w);
			w%=n;
			for(i=0;i<n;i++){
				q=(i+w)%n;
				h=i-w;
				if(h<0)
					h+=n;
				dp[(f+1)%2][q]+=dp[f][i]*0.5;
				dp[(f+1)%2][h]+=dp[f][i]*0.5;
				dp[f][i]=0;
			}
			f=(f+1)%2;
		}
		for(i=l-1;i<r;i++)
			ans+=dp[f][i];
		printf("%.4lf\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值