UVA 12709 Falling Ants(简单的比较大小)



Input
The input file contains at most 500 test cases. The description of each test case is given below:
First line of each test case contains an integer T (T ≤ 100) which denotes the total number of ants
to consider. Each of the next T lines contains three integers which denote the value of L, W and H
(1 ≤ L,W,H ≤ 50) of an ant respectively.
Input is terminated by a line containing a single zero.
Output
For each set of input produce one line of output. This line contains the volume of the ant that has the
highest downward acceleration. If there is a tie report the ant with the highest volume.
Sample Input
3
3 4 5
12 1 5
20 10 4
3
3 4 5
20 30 5
1 2 4
0
Sample Output
60
3000

AC代码:

#include <stdio.h>
//author:XXYY
int main(){
	int T,l,w,h,maxh,t,max;
	while(~scanf("%d",&T),T){
		t=1;
		maxh=max=0;
		while(T--){
			scanf("%d%d%d",&l,&w,&h);
			if(t){
				maxh=h;
				max=l*w*h;
				t=0;
			}
			else{
				if(maxh<h){
					maxh=h;
					max=l*w*h;
				}
				else if(maxh==h)
					if(l*w*h>max)
						max=l*w*h;
			}
		}
		printf("%d\n",max);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值