UVALive 6275 (ACM-ICPC Live Archive: 6275 ) Joint Venture(二分)

Sample Input
1
4
9999998
1
2
9999999
Sample Output
yes 1 9999999

AC代码:

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
#define MAX 1000100
//author:XXYY
int L[MAX];
int main(){
	int X,n,l,r,flag,i;
	while(~scanf("%d",&X)){
		X*=10000000;
		scanf("%d",&n);
		flag=0;
		for(i=0;i<n;i++)
			scanf("%d",&L[i]);
		if(!n||n==1){
			printf("danger\n");
			continue;
		}
		sort(L,L+n);
		l=0;
		r=n-1;
		while(l<r){
			if(L[l]+L[r]==X){
				flag=1;
				printf("yes %d %d\n",L[l],L[r]);
				break;
			}
			else if(L[l]+L[r]<X)
				l++;
			else
				r--;
		}
		if(!flag)
			printf("danger\n");

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值