Text Reverse
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16076 Accepted Submission(s): 6081
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3 olleh !dlrow m'I morf .udh I ekil .mca
Sample Output
hello world! I'm from hdu. I like acm.HintRemember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
AC代码:
#include <stdio.h>
#include <string.h>
//author:XXYY
int main(){
char s[1010];
int t,len,l,i,j;
scanf("%d",&t);
getchar();
while(t--){
gets(s);
l=0;
len=strlen(s);
for(i=0;i<len;i++){
if(s[i]==' '){
for(j=i-1;j>=l;j--)
putchar(s[j]);
printf(" ");
l=i+1;
}
if(i==len-1){
for(j=len-1;j>=l;j--)
putchar(s[j]);
printf("\n");
}
}
}
return 0;
}