Text Reverse

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
 

Sample Output
hello world!
I'm from hdu.
I like acm.


      
      
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 

Author
Ignatius.L
 


#include<stdio.h>
#include<string.h>

int main()
{
    int i=0,num=0,count=0,temp=0,j=1,k=0;
    int a[1000]={0};
    char str[1000];

    scanf("%d",&num);
    getchar();
    for(k=0;k<num;k++)
    {
        gets(str);
        count=strlen(str);
        for(i=0;i<=count;i++)
        {
            if(str[i]==' ')
            {
                a[j]=i;
                temp=a[j];
                while(temp>a[j-1])
                {
                    putchar(str[temp-1]);
                    temp=temp-1;
                }
                if(j==1)
                {
                 putchar(' ');
                }
                j++;
            }
            if(str[i]=='\0')
            {
                temp=i-1;
                while(temp>=(a[j-1]+1))
                {
                    putchar(str[temp]);
                    temp=temp-1;
                }
            }
        }
        a[0]=0;
        i=count=temp=0;
        j=1;
        putchar('\n');
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值