Rightmost Digit
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
AC代码
#include <cstdio>
#include <iostream>
using namespace std;
long long quickpower(long long n)
{
long long base=n,b=n;
long long ans=1;
while(b!=0)
{
if(b&1!=0)
ans=(ans*base)%10;
base=(base*base)%10;
b>>=1;
}
return ans;
}
int main()
{
int num=0;
scanf("%d",&num);
while(num!=0)
{
long long n;
scanf("%lld",&n);
long long nape=quickpower(n);
printf("%lld\n",nape);
num--;
}
}