Cow Contest
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
题目大意:第一行给出两个数n,m,n代表奶牛的数量,m代表m场比赛,下面m行每行有两个整数a,b,代表本场比赛a能够击败b,(注:若a能击败b,b能击败c,则代表a能击败c)问最后能确定多少头奶牛的排名。
解决方法:通过使用floyd算法,将每两头奶牛的胜负关系确定,如果知道一头奶牛与其他所有奶牛的胜负关系,则可推出这头奶牛的排名。
AC代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e3 + 5;
const ll mod = 1e9+7;
bool mapp[maxn][maxn];
int num[maxn];
int n,m;
void floyd()
{
rep(k,1,n) {
rep(i,1,n) {
rep(j,1,n) {
if(mapp[i][k]==true&&mapp[k][j]==true)
mapp[i][j]=true;
}
}
}
}
int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
ios::sync_with_stdio(0),cin.tie(0);
cin>>n>>m;
memset(mapp,false,sizeof(mapp));
while(m--)
{
int a,b;
cin>>a>>b;
mapp[a][b]=true;
}
floyd();
int ans=0;
rep(i,1,n) {
rep(j,1,n) {
if(mapp[i][j]==true||mapp[j][i]==true)
num[i]++;
}
if(num[i]==n-1)
ans++;
}
cout<<ans<<endl;
return 0;
}