N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
题目大意:
给出几组关系,问可以找到几个数的确定位置。
只要一个数和其他的几个数有关系,则此数的位置是确定的。
get新知识~
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
using namespace std;
int ma[121][121];
void Floyd(int n)//Floyd闭包
{
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(ma[i][k]&&ma[k][j])//有关系
ma[i][j] = 1;
}
}
}
}
int main()
{
int n, m;
while(~scanf("%d %d", &n, &m))
{
memset(ma, 0, sizeof(ma));
for(int i=0;i<m;i++)
{
int x, y;
scanf("%d %d", &x, &y);
ma[x][y] = 1;
}
Floyd(n);
int count = 0;//可以确定位置的个数
for(int i=1;i<=n;i++)
{
int flag = 0;
for(int j=1;j<=n;j++)
{
if(i==j)
continue;
if(ma[i][j]==0&&ma[j][i]==0)//如果两数之间没有关系,则跳出
{
flag = 1;
break;
}
}
if(!flag)
count++;
}
cout<<count<<endl;
}
return 0;
}