【差分数组】Master of GCD

题目描述

Hakase has n numbers in a line. At fi rst, they are all equal to 1. Besides, Hakase is interested in primes. She will choose a continuous subsequence [l, r] and a prime parameter x each time and for every l≤i≤r, she will change ai into ai*x. To simplify the problem, x will be 2 or 3. After m operations, Hakase wants to know what is the greatest common divisor of all the numbers.

 

输入

The first line contains an integer T (1≤T≤10) representing the number of test cases.
For each test case, the fi rst line contains two integers n (1≤n≤100000) and m (1≤m≤100000),where n refers to the length of the whole sequence and m means there are m operations.
The following m lines, each line contains three integers li (1≤li≤n), ri (1≤ri≤n), xi (xi∈{2,3} ),which are referred above.

 

输出

For each test case, print an integer in one line, representing the greatest common divisor of the sequence. Due to the answer might be very large, print the answer modulo 998244353.

 

样例输入

复制样例数据

2
5 3
1 3 2
3 5 2
1 5 3
6 3
1 2 2
5 6 2
1 6 2

样例输出

6
2

 

提示

For the first test case, after all operations, the numbers will be [6,6,12,6,6]. So the greatest common divisor is 6.

 

题目大意:

先输入一个整数t,代表有t组测试,对于每组测试,第一行输入两个整数n,m,n代表数组的长度,m代表下面对这个数组进行m此操作,下面m行每行输入三个整数l,r,x,代表将数组从a[l]到a[r]里面每一个数进行乘x操作,x只取2,3两个值,问最后整个数组的最大公约数是多少。

解题思路:

因为只是对数组的某段区间进行乘2或乘3操作,所以可以通过计算数组的每一项元素乘2,乘3的次数,找出最小乘2次数n1,乘3的次数n2,最后的结果就是(2^n1)*(3^n2),所以我们可以通过差分数组进行区间修改的维护,O(1)修改,O(n)查询,最后通过快速幂计算出乘积即可。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 998244353.;
int d1[100100],d2[100100];
ll quickpow(ll base,ll x) {
    ll ans=1;
    while(x) {
        if(x&1) ans=(ans*base)%mod;
        base=(base*base)%mod;
        x>>=1;
    }
    return ans;
}
int main() 
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int t;
    cin>>t;
    while(t--) {
        int n,m;
        cin>>n>>m;
        fill(d1+1,d1+1+n,0);fill(d2+1,d2+1+n,0);
        for(int i=1;i<=m;i++) {
            int a,b,c;
            cin>>a>>b>>c;
            if(c==2) d1[a]++,d1[b+1]--;
            if(c==3) d2[a]++,d2[b+1]--;
        }
        ll nape1=0,nape2=0;
        ll maxl1=inf,maxl2=inf;
        for(int i=1;i<=n;i++) {
            nape1+=d1[i];
            nape2+=d2[i];
            maxl1=min(maxl1,nape1);
            maxl2=min(maxl2,nape2);
        }
        ll ans=(quickpow(2LL,maxl1)*quickpow(3LL,maxl2))%mod;
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值