Little Sub and Counting

题目描述

Little Sub likes Math. Now he has a simple counting problem for you.
Given an positive integer sequence A, for each Ai , Please calculate how many elements Aj in the sequence satisfi ed AiAj > AjAi .

 

输入

The first line contains one positive integer n(1 ≤ n≤100000).
The following line contains n positive integers Ai(1≤Ai≤231-1).

 

输出

Please output n integer in one line and separate them by a single space. The ith integer indicates the answer concerning Ai .

 

样例输入

复制样例数据

3
1 2 5

样例输出

0 2 1

注释:①lower_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,格式:lower_bound(a,a+n,key)-a;

 

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;
typedef long long LL;
double a[100010],b[100010],x;//注意用double,避免精度问题
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%lf",&x);
        a[i]=log(x)/x;
        b[i]=a[i];
    }
    sort(b,b+n);
    int m;
    for(int i=0;i<n;i++){
        m=lower_bound(b,b+n,a[i])-b;
        if(i==n-1)
            printf("%d\n",m);
        else
            printf("%d ",m);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值