DreamGrid has just found an integer sequence in his right pocket. As DreamGrid is bored, he decides to play with the sequence. He can perform the following operation any number of times (including zero time): select an element and move it to the beginning of the sequence.
What's the minimum number of operations needed to make the sequence non-decreasing?
Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:
The first line contains an integer (), indicating the length of the sequence.
The second line contains integers (), indicating the given sequence.
It's guaranteed that the sum of of all test cases will not exceed .
Output
For each test case output one line containing one integer, indicating the answer.
Sample Input
2 4 1 3 2 4 5 2 3 3 5 5
Sample Output
2 0
Hint
For the first sample test case, move the 3rd element to the front (so the sequence become {2, 1, 3, 4}), then move the 2nd element to the front (so the sequence become {1, 2, 3, 4}). Now the sequence is non-decreasing.
For the second sample test case, as the sequence is already sorted, no operation is needed.
注释:b[]里面存放a[]中的最长子序列,c[]里面存放a[]中剩余的数,c[]中的个数是一定要移动的,并且a[]中所有比c[]中最大值的数都要移动,把这些数相加输出即可。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
typedef long long LL;
int a[100010],b[100010],c[100010];
int main()
{
int t;
scanf("%d",&t);
while(t--){
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
int n,jd=1,jx=1;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
if(a[i]>=b[jd-1]){
b[jd++]=a[i];
}else{
c[jx++]=a[i];
}
}
int ma=*max_element(c,c+jx);
jx=jx-1;
for(int i=1;i<jd;i++){
if(b[i]<ma){
jx++;
}
}
cout<<jx<<endl;
}
return 0;
}