HDU 6315 Naive Operations

Naive Operations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 502768/502768 K (Java/Others)
Total Submission(s): 1103    Accepted Submission(s): 450

Problem Description

In a galaxy far, far away, there are two integer sequence a and b of length n.
b is a static permutation of 1 to n. Initially a is filled with zeroes.
There are two kind of operations:
1. add l r: add one for al,al+1...ar
2. query l r: query ∑ri=l⌊ai/bi⌋

Input

There are multiple test cases, please read till the end of input file.
For each test case, in the first line, two integers n,q, representing the length of a,b and the number of queries.
In the second line, n integers separated by spaces, representing permutation b.
In the following q lines, each line is either in the form 'add l r' or 'query l r', representing an operation.
1≤n,q≤100000, 1≤l≤r≤n, there're no more than 5 test cases.

Output

Output the answer for each 'query', each one line.

Sample Input

5 12

1 5 2 4 3

add 1 4

query 1 4

add 2 5

query 2 5

add 3 5

query 1 5

add 2 4

query 1 4

add 2 5

query 2 5

add 2 2

query 1 5

Sample Output

1

1

2

4

4

6

Source

2018 Multi-University Training Contest 2

 


题意:给你两个数组b和a,长度都为n,下面再给你数组b,进行q次操作,add  x   y表示a数组的区间x ~y加1;query则是问你

这个区间的ai / bi 加起来为多少(不带小数)。

刚开始想用树状数组,然后一个小时死活想不出来就放弃,听dls讲也听不懂,后面听学长讲了才有点思路。然后自己按照学长的代码码了一遍。

大致思路:线段树。先存min值,叶子节点为b的值,然后lazy更新,sum求和max是叶子修改的最大值。

#include<bits/stdc++.h>
using namespace std;
#define mem(a,x) memset(a,x,sizeof(a))
const int maxn = 100005;

struct node{
	int l,r,maxA,minB,sum,lazy;
}tree[maxn * 4];

int b[maxn];

void push_up(int rt){
	tree[rt].minB = min(tree[rt << 1].minB,tree[rt << | 1].minB);
	tree[rt].maxA = max(tree[rt << 1].maxA,tree[rt << | 1].maxA);
	tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
}

void push_down(int rt){
	if(tree[rt].lazy){
		tree[rt << 1].lazy += tree[rt].lazy;
		tree[rt << 1 | 1].lazy += tree[rt].lazy;
		tree[rt << 1].maxA += tree[rt].lazy;
		tree[rt << 1 | 1].maxA += tree[rt].lazy;
		tree[rt].lazy = 0;
	}
}

void build_tree(int l,int r,int rt){
	tree[rt].l = l;
	tree[rt].r = r;
	tree[rt].lazy = 0;
	if(l == r){
		tree[rt].minB = b[l];
		tree[rt].sum = 0;
		tree[rt].maxA = 0;
		return ;
	}
	int mid = (1 + r) >> 1;
	build_tree(l,mid,rt << 1);
	build_tree(mid + 1,r,rt << 1 | 1);
	push_up(rt);
}

void update_interval(int l,int r,int rt){
	if(l <= tree[rt].l && r >= tree[rt].r ){
		tree[rt].maxA++;
		if(tree[rt].maxA < tree[rt].minB){
			tree[rt].lazy++;
			return;
		}
		if(tree[rt].l == tree[rt].r && tree[rt].maxA >= tree[rt].minB){
			tree[rt].sum++;
			tree[rt].minB += b[tree[rt].l];
			return ;
		}
	}
	push_down(rt);
	int mid = (tree[rt].l + tree[rt].r) >> 1;
	if(l <= mid){
		updata_interval(l,r,rt << 1);
	}
	if(r > mid){
		updata_interval(l,r,rt << 1 | 1);
	}
	push_up(rt);
}

int query_interval(int l,int r,int rt){
	if(l <= tree[rt].l && r >= tree[rt].r){
		return tree[rt].sum;
	}
	push_down(rt);
	int ans = 0;
	int mid = (tree[rt].l + tree[rt].r) >> 1;
	if(l <= mid){
		ans += query_interval(l,r,rt << 1);
	}
	if(r > mid){
		ans += query_interval(l,t,rt << 1 | 1);
	}
	return ans;
}
int main(){
	int n,m,l,r;
	char opt[10];
	while(scanf("%d %d",&n,&m) != EOF){
		for(int i = 1;i <= n;i++){
			scanf("%d",&b[i]);
		}
		build_tree(1,n,1);
		while(m--){
			scanf("%s %d %d",opt,&l,&r);
			if(opt[0] == 'a'){
				update_interval(l,r,1);
			}else{
				printf("%d\n",query_interval(l,r,1));
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值