#1135 : Magic Box

#1135 : Magic Box
时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述

The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some
balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and
blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. 
Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box 
vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find
what is the maximum number of balls in the box ever.


For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts 
the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The 
differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls 
vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the 
box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

输入

Line 1: x y z

Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.

For 30% data, the length of the sequence is no more than 200.

For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

输出

The maximum number of balls in the box ever.

提示

Another Sample
Sample InputSample Output
0 0 0
RBYRRBY4

样例输入

1 2 3
RRYBRBRYBRY

样例输出

7

C语言:

//cr,cy,cb三个差值等于x,y,z即可,无需考虑顺序
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int yxh(const void *p1,const void *p2)
{
	return *(int *)p1-*(int *)p2;
}
int main()
{
	int cr,cy,cb,a[3],b[3],i,max;
	char s[20001];
	scanf("%d%d%d",&a[0],&a[1],&a[2]);
	scanf("%s",&s);
	qsort(a,3,sizeof(int),yxh);//快排
	for(i=cr=cy=cb=max=0; s[i]!='\0'; i++)
	{
		if(s[i]=='R')
		{
			cr++;
		}
		else if(s[i]=='Y')
		{
			cy++;
		}
		else if(s[i]=='B')
		{
			cb++;
		}
		b[0]=abs(cr-cy);
		b[1]=abs(cr-cb);
		b[2]=abs(cy-cb);
		qsort(b,3,sizeof(int),yxh);//快排
		if(a[0]==b[0]&&a[1]==b[1]&&a[2]==b[2])
		{
			if(max<cr+cy+cb)
			{
				max=cr+cy+cb;
			}
			cr=cy=cb=0;
		}
	}
	if(max<cr+cy+cb)
	{
		max=cr+cy+cb;
	}
	printf("%d",max);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值