#1135 : Magic Box(枚举)

#1135 : Magic Box

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.

For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

输入

Line 1: x y z

Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.

For 30% data, the length of the sequence is no more than 200.

For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

输出

The maximum number of balls in the box ever.

提示

Another Sample

Sample InputSample Output
0 0 0
RBYRRBY            
4



样例输入
1 2 3
RRYBRBRYBRY
样例输出
7

题意:

一个字符串三种字母代表三种颜色,按顺序从头到尾输入。给你三个数字x,y,z,倘若三种颜色差恰好等于x,y,z那么气球将爆炸,然后继续输入未输入完成的,知道输入完或者再次爆炸,求爆炸区段里最大的一段。

思路:

a数组存放xyz,b数组存放差,b[0]=R-Y,b[1]=R-B,b[2]=Y-B;然后加一个判断看是否爆炸

代码:

/*
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
#define INF 1e9
const int maxn=5000+100;
typedef long long ll;
using namespace std;
bool ok(int a[],int b[]){
    int c[3];
    memset(c,0,sizeof(c));
    for(int i=0;i<3;i++) c[i]=abs(b[i]);
    sort(c,c+3);
    for(int i=0;i<3;i++)
        if(a[i]!=c[i])
        return false;
    return true;
}
int main(){
    int a[3];
    int b[3];
    string s;
    while(cin>>a[0]>>a[1]>>a[2]){
        sort(a,a+3);
        cin>>s;
        int len=s.length();
        int ans=0;
        int maxx=0;
        memset(b,0,sizeof(b));
        for(int i=0;i<len;i++){
            if(s[i]=='R'){
                b[0]++;
                b[1]++;
            }
            else if(s[i]=='Y'){
                b[0]--;
                b[2]++;
            }
            else if(s[i]=='B'){
                b[1]--;
                b[2]--;
            }
            ans++;
            if(ok(a,b)){
                if(maxx<ans)
                    maxx=ans;
                ans=0;
                memset(b,0,sizeof(b));
            }


        }
        if(maxx<ans) maxx=ans;
        cout<<maxx<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值