错了两次,就是知先序和中序求后序的,但是不能用字符串,因为输入中间有空格,输出也有空格

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 
 

Output

For each test case print a single line specifying the corresponding postorder sequence. 
 

Sample Input

       
       
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output

       
       
7 4 2 8 9 5 6 3 1
 


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int a[1005],b[1005];
int c[1005],s;
struct node
{
    int data;
    struct node *l,*r;
};
struct node *build(int *a,int *b,int t)
{
    struct node *root;
    int i;
    if(t<=0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    for(i=0; i<t; i++)
    {
        if(b[i]==*a)
            break;
    }
    root->data=*a;
    root->l=build(a+1,b,i);
    root->r=build(a+1+i,b+1+i,t-1-i);
    return root;
}
void last(struct node *root)
{
    if(root!=NULL)
    {
        last(root->l);
        last(root->r);
        c[s++]=root->data;
    }
}
int main()
{
    int n,i;
    struct node *root;
    while(~scanf("%d",&n))
    {
        s=0;
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(i=0; i<n; i++)
            scanf("%d",&b[i]);
        root=build(a,b,n);
        last(root);
        for(i=0; i<s; i++)
        {
            printf("%d",c[i]);
            if(i<s-1)
                printf(" ");
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值