搞不懂啊,为什么会这样,连结果都输不出来,怎么就AC了呢?

写这么多,就是找前缀,还不能和别的字符串重复

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char a[1005][25],b[25];
struct node
{
    int flag;
    struct node *next[26];
};
struct node *creat()//建树
{
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    int i;
    for(i=0; i<26; i++)
    {
        root->next[i]=NULL;
    }
    root->flag=0;
    return root;
}
void Insert(struct node *root,char *a)
{
    int num,len,i;
    struct node *p;
    p=root;
    len=strlen(a);
    for(i=0; i<len; i++)
    {
        num=a[i]-'a';
        if(p->next[num]==NULL)
        {
            p->next[num]=creat();
        }
        p=p->next[num];
        p->flag+=1;//共同部分加一

    }
    p->flag+=1;//若p->flag不为1,说明此处为共同部分
}
void Search(struct node *root,char *b)
{
    struct node *p;
    int num,i,len,j;
    p=root;
    len=strlen(b);
    for(i=0; i<len; i++)
    {
        num=b[i]-'a';

        if(p->flag==1)//p->flag=1说明此处为这个字符串独有的一个链,独有部分
        {
            for(j=0; j<i; j++)//输出所谓的“前缀”
            {
                printf("%c",b[j]);
            }
            return;//输出后就结束循环,进行下一个字符串
        }

        p=p->next[num];
    }
    printf("%s",b);//此处为所有都遍历过,都不为1,则输出整个字符串
}
void Delete(struct node *root)
{
    int i;
    for(i=0; i<26; i++)
    {
        if(root->next[i]!=NULL)
            Delete(root->next[i]);
    }
    free(root);
    root=NULL;
}
int main()
{
    int n,m,num,i;
    struct node *root;
    root=creat();
    n=0;
    while(~ scanf("%s",a[n]))//此处输入字符串
    {
        Insert(root,a[n++]);//插入树中
    }
    for(i=0; i<n; i++)
    {
        printf("%s ",a[i]);
        Search(root,a[i]);
        printf("\n");

    }
    Delete(root);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值