a letter and a number



a letter and a number描述

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
解题思路:
本题涉及n组数据,而每组数据开头都是字符,scanf读取字符是会先读取换行,所以应当在读取每行数据之前,用getchar将回车吃掉,否知只能读取一半数据。
程序代码:
#include<stdio.h>
int main()
{
	int n,y,i;
	char x;
	scanf("%d",&n);
	while(n--)
	{
		getchar();
		scanf("%c%d",&x,&y);
		if(x>='a'&&x<='z')
			printf("%d\n",'a'-x-1+y);
		else if(x>='A'&&x<='Z')
			printf("%d\n",x-'A'+1+y);

	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值