L1-023 输出GPLT

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

 

思路:输出统计每个字符的个数,按照顺序依次还有余额就输出。

#include <iostream>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <cstdio>
#include <cmath>
#include <set>
#include <algorithm>
#include <iterator>
#include <cstdlib>
using namespace std;

int main() {
  //freopen("in.txt", "r", stdin);
  int x1 = 0, x2 = 0, x3 = 0 , x4 = 0;
  char x;
  while(cin >> x) {
    switch (x){
      case 'G': x1++;break;
      case 'P': x2++;break;
      case 'L': x3++;break;
      case 'T': x4++;break;
      case 'g': x1++;break;
      case 'p': x2++;break;
      case 'l': x3++;break;
      case 't': x4++;break;
    }
  }
  int flag = 0;
  do{
    flag = 0;
    if (x1) {
      flag = 1;
      cout << 'G';
      x1--;
    }
    if (x2) {
      flag = 1;
      cout << 'P';
      x2--;
    }
    if (x3) {
      flag = 1;
      cout << 'L';
      x3--;
    }
    if (x4) {
      flag = 1;
      cout << 'T';
      x4--;
    }
  }while(flag);
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值