WOLF AND RABBIT

Description

There is a hill with n holes around. The holes are signed from 0 to n-1.
 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

 

Sample Input

 

2 1 2 2 2

 

Sample Output

 

NO

YES

 

主要就是求两个数之间的最大公因数,在这里用的是辗转相除法求最大公因数,但是还要注意的一点是分母为0的情况,这点要注意
#include<bits/stdc++.h>

using namespace std;

int aa(int x, int y)
{
	int t;
	do
	{
		if(x<y)
		{
			swap(x,y);
		}
		x=x%y;
	}while(x);
	return y;
}



int main()
{
    int m,n,p;
    int i;
    scanf("%d",&p);
    while(p--)
    {
        scanf("%d %d",&m,&n);
        if(aa(m,n)!=1)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值