解决macOS 10.13下 homebrew 一安装报错问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/YanceChen2013/article/details/81288527

解决macOS 10.13下 homebrew 一安装报错问题

错误描述:Error downloading Command Line Tools (macOS High Sierra version 10.13) for Xcode

在终端敲命令:/usr/bin/ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”安装homebrew出现上述错误

这个原因是因为之前我从apple官网上下了最新的xcode-9.4新版,新版的可能跟旧版的好像不太一样,xcode的命令行工具不再安装在
/Library/Developer/CommandLineTools 这个位置了,这个时候只需要使用这个命令设置一下就可以了:
sudo xcode-select –switch /Applications/Xcode.app

最后再输入命令这个验证一下:
xcode-select -p

打印输出:
/Applications/Xcode.app/Contents/Developer

这样再回头去安装homebrew 就一切正常了!
这里写图片描述

OK,大功告成!!!

展开阅读全文

没有更多推荐了,返回首页