[网络流 24 题] luoguP2756 飞行员配对方案问题

[返回网络流 24 题索引]

题目描述

英国皇家空军从沦陷国征募了大量外籍飞行员。由皇家空军派出的每一架飞机都需要配备在航行技能和语言上能互相配合的 2 2 2 名飞行员,其中 1 1 1 名是英国飞行员,另 1 1 1 名是外籍飞行员。在众多的飞行员中,每一名外籍飞行员都可以与其他若干名英国飞行员很好地配合。如何选择配对飞行的飞行员才能使一次派出最多的飞机。对于给定的外籍飞行员与英国飞行员的配合情况,试设计一个算法找出最佳飞行员配对方案,使皇家空军一次能派出最多的飞机。

对于给定的外籍飞行员与英国飞行员的配合情况,编程找出一个最佳飞行员配对方案,使皇家空军一次能派出最多的飞机。

输入格式

1 1 1 行有 2 2 2 个正整数 m m m n n n n n n 是皇家空军的飞行员总数 ( n &lt; 100 ) (n&lt;100) (n<100) m m m 是外籍飞行员数 ( m ≤ n ) (m\leq n) (mn)。外籍飞行员编号为 1 ∼ m 1\sim m 1m;英国飞行员编号为 m + 1 ∼ n m+1\sim n m+1n

接下来每行有 2 2 2 个正整数 i i i j j j,表示外籍飞行员 i i i 可以和英国飞行员 j j j 配合。最后以 2 2 2 − 1 -1 1 结束。

输出格式

1 1 1 行是最佳飞行员配对方案一次能派出的最多的飞机数 M M M。接下来 M M M 行是最佳飞行员配对方案。每行有 2 2 2 个正整数 i i i j j j,表示在最佳飞行员配对方案中,飞行员 i i i 和飞行员 j j j 配对。如果所求的最佳飞行员配对方案不存在,则输出No Solution!

输入样例

5 10
1 7
1 8
2 6
2 9
2 10
3 7
3 8
4 7
4 8
5 10
-1 -1

输出样例(Special Judge)

4
1 7
2 9
3 8
5 10 

Solution P2756 \text{Solution P2756} Solution P2756

在这里插入图片描述
将英国飞行员放在左边一组,外籍飞行员放右边一组,完成建图。

#include<cstdio>
#include<cstdlib>
#include<cstring>

#define reg register

struct node{
	int x,y,d,next,other;
}e[22000];
int len=0;
int n,m;
int first[210];
int h[210];
int q[1000010];
int st,ed;
int s1,s2;
const int ST=201,ED=202;
int mh[210];

void ins(int x,int y,int d){
	e[++len].x=x;e[len].y=y;e[len].d=1;
	e[len].next=first[x];first[x]=len;
	e[++len].x=y;e[len].y=x;e[len].d=0;
	e[len].next=first[y];first[y]=len;
	e[len].other=len-1;
	e[len-1].other=len;
}
bool bfs(){
	memset(h,0,sizeof(h));h[ST]=1;
	st=1;ed=2;q[st]=ST;
	while(st!=ed){
		int x=q[st];
		for(reg int i=first[x];i;i=e[i].next){
			int y=e[i].y;
			if(!h[y]&&e[i].d){
				h[y]=h[x]+1;
				q[ed++]=y;
			}
		}
		++st;
	}
	if(h[ED]>0) return 1;
	return 0;
}
#define min(x,y) ((x)<(y)?(x):(y))

int dfs(int x,int f){
	if(x==ED) return f;
	int tt=0;
	for(reg int i=first[x];i;i=e[i].next){
		int y=e[i].y;
		if(h[y]==h[x]+1&&e[i].d>0&&f>tt){
			int my=dfs(y,min(f-tt,e[i].d));
			e[i].d-=my;
			e[e[i].other].d+=my;
			tt+=my;
			if(my&&x!=ST&&x!=ED&&y!=ST&&y!=ED)
				mh[x]=y;
			if(tt==f) return f;
		}
	}
	if(!tt) h[x]=0;
	return tt;
}
int main(){
	scanf("%d%d",&m,&n);
	do{
		scanf("%d%d",&s1,&s2);
		if(s1==-1&&s2==-1) break;
		ins(s1,s2,1);
	}while(s1!=-1||s2!=-1);
	for(reg int i=1;i<=m;++i)
		ins(ST,i,1);
	for(reg int i=m+1;i<=n;++i)
		ins(i,ED,1);
	int ans=0;
	while(bfs()) ans+=dfs(ST,0x3f3f3f3f);
	if(!ans){
		puts("No Solution!");
		exit(0);
	}
	printf("%d\n",ans);
	for(reg int i=1;i<=m;++i)
		if(mh[i])
			printf("%d %d\n",i,mh[i]);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
网络算法可以用来解决最大最小割问题,而飞行员配对问题可以转化成最大问题。下面是一个基于 Python 的网络算法求解飞行员配对方案问题的示例代码: ```python from collections import defaultdict class Graph: def __init__(self): self.graph = defaultdict(dict) def add_edge(self, u, v, w): self.graph[u][v] = w def bfs(self, s, t, parent): visited = set() queue = [s] visited.add(s) while queue: u = queue.pop(0) for v in self.graph[u]: if v not in visited and self.graph[u][v] > 0: queue.append(v) visited.add(v) parent[v] = u return True if t in visited else False def max_flow(self, source, sink): parent = {} max_flow = 0 while self.bfs(source, sink, parent): path_flow = float('inf') s = sink while s != source: path_flow = min(path_flow, self.graph[parent[s]][s]) s = parent[s] max_flow += path_flow v = sink while v != source: u = parent[v] self.graph[u][v] -= path_flow self.graph[v][u] += path_flow v = parent[v] return max_flow def pilot_pairing(pilots, planes): num_pilots = len(pilots) num_planes = len(planes) graph = Graph() source = 's' sink = 't' for i in range(num_pilots): graph.add_edge(source, 'P{}'.format(i), 1) for j in range(num_planes): if pilots[i][0] <= planes[j][0] and pilots[i][1] >= planes[j][1]: graph.add_edge('P{}'.format(i), 'A{}'.format(j), 1) graph.add_edge('A{}'.format(i), sink, 1) return graph.max_flow(source, sink) # 示例用法 pilots = [(1, 5), (2, 4), (3, 6), (2, 5)] planes = [(1, 4), (2, 5), (3, 6)] print(pilot_pairing(pilots, planes)) # 输出为 3 ``` 在上面的示例代码中,我们定义了一个 `Graph` 类来表示图,其中 `add_edge` 方法用于添加边,`bfs` 方法用于执行广度优先搜索,`max_flow` 方法用于计算最大。 在 `pilot_pairing` 函数中,我们首先创建了一个 `Graph` 对象,然后为源点和汇点分别添加一条边,并遍历所有的飞行员和飞机,如果某个飞行员可以驾驶某个飞机,则在他们之间添加一条边。最后调用 `max_flow` 方法计算最大。 在 `max_flow` 方法中,我们首先执行广度优先搜索来寻找一条增广路径,然后计算路径上的最小剩余容量,更新路径上的边的量,并更新最大的值。重复执行这个过程,直到没有增广路径为止。最后返回最大的值。 在上面的示例中,我们输入了 4 个飞行员和 3 个飞机,输出得到了最大为 3,说明有 3 对飞行员和飞机可以配对成功。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值