1017. Queueing at Bank (25)

题目:

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

注意:
1、处理好题中的几个条件:不接收晚于17:00:00的客户;早于8:00:00的客户需要等到这个时间才能接受服务。
2、注意有可能有客户到达银行的时候有空余的窗口,这时候要注意设置判断条件。
3、下面的代码中有serTime的代码行均可以删掉,不影响最后的计算结果。


代码:
#include<iostream>
#include<vector>
#include<algorithm>
#include<iomanip>
using namespace std;

struct customer
{
	//all time count in seconds
	int arrTime;//arriving time
	int proTime;//processing time
	int serTime;//service time
	bool operator < (const customer &c) const
	{
		return arrTime<c.arrTime;
	}
};
vector<customer>cus;

int main()
{
	int N,K;
	cin>>N>>K;
	int i;
	for(i=0;i<N;++i)
	{
		customer c;
		int hour,minute,second;
		cin>>hour;
		getchar();
		cin>>minute;
		getchar();
		cin>>second;
		c.arrTime=(hour-8)*3600+minute*60+second;
		cin>>c.proTime;
		c.proTime*=60;
		c.serTime=0;
		cus.push_back(c);
	}
	std::sort(cus.begin(),cus.end());
	vector< int>winTime(K,0);//windows current service time
	int totalWaiTime=0;
	for(i=0;i<N;++i)
	{
		//if the new customer arrive later than 17:00:00, stop the sevice
		if(cus.at(i).arrTime>9*3600)
			break;
		int index=0;
		int t=winTime.at(0);
		//choose window with the earlist service time
		for(int j=1;j<K;++j)
		{
			if(winTime.at(j)<t)
			{
				index=j;
				t=winTime.at(j);
			}
		}
		//if the chosen window is vacant when customer arrive
		//enjoy the service right now,and the window start to work
		if(cus.at(i).arrTime>t)
		{
			cus.at(i).serTime=cus.at(i).arrTime;
			winTime.at(index)=cus.at(i).arrTime;
		}
		//if not vacant, wait
		else
		{
			cus.at(i).serTime=t;
			totalWaiTime += t-cus.at(i).arrTime;
		}
		//if customer's processing time exceed an hour,provide only an hour
		//refresh the window service time
		if(cus.at(i).proTime>3600)
			winTime.at(index) += 3600;
		else
			winTime.at(index) += cus.at(i).proTime;

	}
	cout<<setiosflags(ios::fixed)<<setprecision(1)<<totalWaiTime/60.0/i<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值