1067. Sort with Swap(0,*) (25)

题目:

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9
注意:
1、题目中的方法是每次找到0所在的位置,然后再找到0所在位置应该放置的数字进行调换,这样的话每次都要做两次搜索,时间开销较大。
2、较好的思路是当索引为0的位置的数字不为0时,就把这个数字与这个数字应该放置的位置的数字调换,这样每次调换都可以让一个在错误位置的数字回到对应的正确位置。
3、在上述调换过程中会出现0被置换到0位置的时候,由于要求必须是swap(0,*),所以这个时候要找到一个不在正确位置的数字与0调换,然后继续2的操作,直到全部归位。

代码:
//1067
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	int n,count=0,wrongpos=0;
	vector<int>test;
	scanf("%d",&n);
	test.resize(n);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&test[i]);
		if(test[i]!=i)
			++wrongpos;//number of wrong position nodes
	}
	int index=1;//record the index of the first wrong position node
	while(wrongpos)
	{
		++count;
		if(test[0]!=0)
		{//swap test[0] to its correct position
			swap(test[test[0]],test[0]);
			//if 0 has swaped to it position also, the wrongpos decrease by 2 
			if(test[0]==0)
				wrongpos -= 2;
			else --wrongpos;
		}
		else
		{//if 0 is on its position, find the nearest node in wrong position
			while(test[index]==index)++index;
			swap(test[index],test[0]);
			//wrongpos increase because 0 has been swaped to a wrong position
			++wrongpos;
		}
	}
	printf("%d\n",count);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值