POJ 1930 Dead Fraction (无限循环小数转化为分数)

21 篇文章 0 订阅
20 篇文章 0 订阅
Dead Fraction
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 2597 Accepted: 845

Description

Mike is frantically scrambling to finish his thesis at the last minute. He needs to assemble all his research notes into vaguely coherent form in the next 3 days. Unfortunately, he notices that he had been extremely sloppy in his calculations. Whenever he needed to perform arithmetic, he just plugged it into a calculator and scribbled down as much of the answer as he felt was relevant. Whenever a repeating fraction was displayed, Mike simply reccorded the first few digits followed by "...". For instance, instead of "1/3" he might have written down "0.3333...". Unfortunately, his results require exact fractions! He doesn't have time to redo every calculation, so he needs you to write a program (and FAST!) to automatically deduce the original fractions.
To make this tenable, he assumes that the original fraction is always the simplest one that produces the given sequence of digits; by simplest, he means the the one with smallest denominator. Also, he assumes that he did not neglect to write down important digits; no digit from the repeating portion of the decimal expansion was left unrecorded (even if this repeating portion was all zeroes).

Input

There are several test cases. For each test case there is one line of input of the form "0.dddd..." where dddd is a string of 1 to 9 digits, not all zero. A line containing 0 follows the last case.

Output

For each case, output the original fraction.

Sample Input

0.2...
0.20...
0.474612399...
0

Sample Output

2/9
1/5
1186531/2500000

Hint

Note that an exact decimal fraction has two repeating expansions (e.g. 1/5 = 0.2000... = 0.19999...).

Source


题目大意:

    给出一个省略了后面部分小数部分的小数,求用给出的部分的部分或整个作为循环节得到的分母最小的分数。


解题思路:

    对于任意一个[0.1,1)的无限循环小数有有转化为分数的公式:(小数部分(非循环节部分与一个循环节组成)-小数非循环节部分)/999...000(9的个数是循环节部分的位数,0的个数是非循环节部分的位数)。

具体的公式推导证明见此:http://www.guokr.com/question/486196/

    由于题目要求分母最小,只需要枚举一遍哪些部分做循环节再找到分母最小的即可。


附AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

const int INF=0x3f3f3f3f;
string in;

int to_int(int a,int b)//将字符串中[a,b]部分转化为数字
{
    if(a>b)
        return 0;
    int res=0;
    for(int i=a;i<=b;++i)
        res=res*10+in[i]-'0';
    return res;
}

int main()
{
    while(cin>>in&&in!="0")
    {
        int ans_up=INF,ans_down=INF;
        int len=in.size();
        len-=3;
        for(int i=len-1;i>=2;--i)//枚举循环节
        {
            int up=to_int(2,len-1)-to_int(2,i-1),down=0;
            for(int j=i;j<len;++j)
                down=down*10+9;
            for(int j=2;j<i;++j)
                down*=10;
            int gcd=__gcd(up,down);//约分
            up/=gcd;
            down/=gcd;
            if(down<ans_down)//找到分母最小的答案
            {
                ans_up=up;
                ans_down=down;
            }
        }
        printf("%d/%d\n",ans_up,ans_down);
    }
    
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值