HDU 4081 Qin Shi Huang's National Road System(次小生成树变形)

87 篇文章 0 订阅

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7530    Accepted Submission(s): 2649


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
  
  
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
  
  
65.00 70.00
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4085  4082  4089  4090  4087 

题目大意:

    给你坐标系上的一些有权值点,让你求一颗生成树,选择一条边使得:这条边相邻的两个点权制/树上除了这条边其他边距离之和最大。


解题思路:

    从题意上就和次小生成树比较像,解题方式也和次小生成树相同。

    先用prim求最小生成树,并同时求的树上任意两点之间的最长边。然后枚举所有原图的边,如果这条边在最小生成树上,就直接减去这条边的长度计算,否则减去这两个点之间最长边的长度计算。


AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
using namespace std;
#define INF 0x3f3f3f3f
#define fi first
#define se second

const int MAXN=1000+3;
pair<int,int> point[MAXN];
int N,pop[MAXN],pre[MAXN];
double G[MAXN][MAXN];//原图
double mincost[MAXN];//从集合X发出的边到每个顶点的最小权值
double save_max[MAXN][MAXN];//任意两点之间的最大边
bool used[MAXN];//顶点i是否包含在集合X中
bool in_tree[MAXN][MAXN];//保存一条边是否在最小生成树中

double prim()
{
    double res=0;
    for(int i=0;i<N;++i)//初始化
    {
        mincost[i]=INF;
        used[i]=false;
        pre[i]=0;
        for(int j=0;j<N;++j)
        {
            save_max[i][j]=0;
            in_tree[i][j]=false;
        }
    }
    mincost[0]=0;
    while(true)
    {
        int v=-1;
        //从不属于X的顶点中选取从X到其权值最小的顶点
        for(int u=0;u<N;++u)
        {
            if(!used[u]&&(v==-1||mincost[u]<mincost[v]))
                v=u;
        }
        if(v==-1)//已经扩展到所有点
            break;
        used[v]=true;//把定点v加入X
        in_tree[v][pre[v]]=in_tree[pre[v]][v]=true;//记录这条边在最小生成树上
        res+=mincost[v];//把这条边的权值加入结果
        for(int u=0;u<N;++u)
        {
            if(u==v)
                continue;
            if(used[u])//类似于dp的方式转移任意两点之间的最长边
                save_max[u][v]=save_max[v][u]=max(save_max[u][pre[v]],mincost[v]);
            else if(mincost[u]>G[v][u])//更新不在X中的点到X的最小距离
            {
                mincost[u]=G[v][u];
                pre[u]=v;
            }
        }
    }
    return res;
}

inline double get_dis(int i,int j)//计算距离
{
    return sqrt(1.0*(point[i].fi-point[j].fi)*(point[i].fi-point[j].fi)+(point[i].se-point[j].se)*(point[i].se-point[j].se));
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        for(int i=0;i<N;++i)
        {
            scanf("%d%d%d",&point[i].fi,&point[i].se,&pop[i]);
            G[i][i]=INF;
            for(int j=0;j<i;++j)
                G[i][j]=G[j][i]=get_dis(i,j);
        }
        double length=prim(),ans=0;
        for(int i=0;i<N;++i)//枚举原图所有边
            for(int j=i+1;j<N;++j)
            {
                if(in_tree[i][j])//边在最小生成树上
                    ans=max(ans,(pop[i]+pop[j])/(length-G[i][j]));
                else ans=max(ans,(pop[i]+pop[j])/(length-save_max[i][j]));//不在最小生成树上
            }
        printf("%.2f\n",ans);
    }
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值