HDU 1043 Eight(康托展开)

20 篇文章 0 订阅
4 篇文章 0 订阅

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23953    Accepted Submission(s): 6400
Special Judge


Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement.
 

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8
 

Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input
  
  
2 3 4 1 5 x 7 6 8
 

Sample Output
  
  
ullddrurdllurdruldr
 

Source
 

Recommend
JGShining
 

题目大意:

    超级经典的八数码问题。

    一个九宫格上有一个空位,求移到初始状态的最短方案。


解题思路:

    这题有很多写法,这里就利用康托展开保存状态来写了。

    康托展开是对于全排列的一种效率非常高的可还原状压方式。对于n个数的全排列状态数为n!。

    由于这题所有情况的终态相同,所以我们就可以从终态倒推出所有合法状态,存下来。然后就可以对于每个输入O(1)查询结果了。


AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define mem(a,b) memset((a),(b),sizeof(a))

const int MAXS=362880+3;//9!
const int MAXN=9;
const int sup[]={1,1,2,6,24,120,720,5040,40320};//阶乘表,用于康托展开
int maze[MAXN];//保存棋盘状态的临时数组
string s;
char ans[MAXS];//从上一个状态走到当前状态的移动方向
int path[MAXS];//走到的下一个状态
queue<int> que;
int init_id;//最终状态id

int get_id()//康托展开
{
    int res=0;
    for(int i=0;i<9;++i)
    {
        int cnt=0;//剩下中第几小
        for(int j=i+1;j<9;++j)
            if(maze[j]<maze[i])
                ++cnt;
        res+=cnt*sup[8-i];
    }
    return res;
}

void get_statue(int id)//通过康托逆展开生成状态
{
    int a[MAXN];//存剩下中第几小
    bool used[MAXN];//是否已用
    for(int i=8;i>=0;--i)
    {
        used[i]=false;
        a[8-i]=id/sup[i];
        id%=sup[i];
    }
    int cnt;
    for(int i=0;i<MAXN;++i)
    {
        cnt=0;
        for(int j=0;j<MAXN;++j)
            if(!used[j])
            {
                if(cnt==a[i])
                {
                    maze[i]=j;
                    used[j]=true;
                    break;
                }
                else ++cnt;
            }
    }
}

void init()//bfs倒推预处理出所有结果
{
    mem(path,-1);
    for(int i=0;i<MAXN;++i)
        maze[i]=(i==8)?0:i+1;
    init_id=get_id();
    que.push(init_id);
    while(!que.empty())
    {
        int now=que.front(); que.pop();
        get_statue(now);
        int p=-1;//x的位置
        for(int i=0;i<MAXN;++i)
            if(maze[i]==0)
                p=i;
        if(p!=0&&p!=3&&p!=6)//x左移
        {
            swap(maze[p],maze[p-1]);
            int next=get_id();
            if(next!=init_id&&path[next]==-1)//新状态
            {
                path[next]=now;
                ans[next]='r';//因为是倒推,所以方向反向
                que.push(next);
            }
            swap(maze[p],maze[p-1]);
        }
        if(p!=2&&p!=5&&p!=8)//x右移
        {
            swap(maze[p],maze[p+1]);
            int next=get_id();
            if(next!=init_id&&path[next]==-1)
            {
                path[next]=now;
                ans[next]='l';
                que.push(next);
            }
            swap(maze[p],maze[p+1]);
        }
        if(p<6)//x下移
        {
            swap(maze[p],maze[p+3]);
            int next=get_id();
            if(next!=init_id&&path[next]==-1)
            {
                path[next]=now;
                ans[next]='u';
                que.push(next);
            }
            swap(maze[p],maze[p+3]);
        }
        if(p>2)//x上移
        {
            swap(maze[p],maze[p-3]);
            int next=get_id();
            if(next!=init_id&&path[next]==-1)
            {
                path[next]=now;
                ans[next]='d';
                que.push(next);
            }
            swap(maze[p],maze[p-3]);
        }
    }
}

int main()
{
    init();
    cin.sync_with_stdio(false);//取消流同步
    while(getline(cin,s))
    {
        int tmp=0;
        for(int i=0;i<s.length();++i)
            if(s[i]!=' ')
                if(s[i]=='x')
                    maze[tmp++]=0;
                else maze[tmp++]=s[i]-'0';
        int id=get_id();
        if(id!=init_id&&path[id]==-1)
            cout<<"unsolvable";
        while(path[id]!=-1)
        {
            cout<<ans[id];
            id=path[id];
        }
        cout<<'\n';
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值