POJ 2253 Frogger(最长边最短路)

87 篇文章 0 订阅

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44668 Accepted: 14235

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n. 

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one. 

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source


题目大意:

    给一个图,求从一个点到另一个点的路径中,最长边最短的路径的最长边。


解题思路:

    这题是最小化最大值,第一眼感觉可以用二分写,但是这题要输出小数,如果二分的话要跑很多很多次最短路,很有可能超时。

    回想最短路的更新方式,如果用dist数组存路径最长边,也是满足松弛操作的,所以我们就可以直接用最短路稍微改一下松弛就可以了。


AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <map>
#include <cmath>
using namespace std;
#define INF 0x3f3f3f3f
#define fi first
#define se second
#define mem(a,b) memset((a),(b),sizeof(a))

const int MAXV=200+3;
pair<double,double> p[MAXV];//坐标
int V;
bool vis[MAXV];
double dis[MAXV];//路径最长边的长度

inline double get_dis(int u,int v)//求任意两点之间距离
{
    return sqrt((p[u].fi-p[v].fi)*(p[u].fi-p[v].fi)+(p[u].se-p[v].se)*(p[u].se-p[v].se));
}

void spfa()
{
    mem(vis,0);
    for(int i=0;i<V;++i)
        dis[i]=INF;
    vis[0]=true;
    dis[0]=0;
    queue<int> que;
    que.push(0);
    while(!que.empty())
    {
        int u=que.front(); que.pop();
        vis[u]=false;
        for(int v=0;v<V;++v)
            if(dis[v]>max(dis[u],get_dis(u,v)))
            {
                dis[v]=max(dis[u],get_dis(u,v));
                if(!vis[v])
                {
                    vis[v]=true;
                    que.push(v);
                }
            }
    }
}

int main()
{
    int cas=1;
    while(~scanf("%d",&V)&&V)
    {
        for(int i=0;i<V;++i)
            scanf("%lf%lf",&p[i].fi,&p[i].se);
        spfa();
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",cas++,dis[1]);
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值