8.23 训练18 并查集

并查集

用来解决极大联通子图的问题。用树状结构记录,记录每一个节点的父节点。
模板
(已加入路径压缩)

int search(int x)
{
  if(us[x].pa==-1)
	return x;
  us[x].pa=search(us[x].pa);
  return us[x].pa;
}

题目

How Many Tables

畅通工程

More is better

Farm Irrigation


今天四道题全部一次A,可喜可贺。晚上出去遛弯了,舒服。不过昨天拉下的两道题和课上老师让作的题实在实在是不想写了。我怎么能这么懒。。。


How Many Tables

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4
问题大意给你一堆关系,问一共有多少个并查集

//You has the final say in what kind of life you want.
#include<iostream>
#include<cstdio>
#include<cstring>
#define MAX 1000+10
using namespace std;
int guest[MAX],n;
int findfa(int x)
{
	if(guest[x]==-1)
		return x;
	guest[x]=findfa(guest[x]);
	return guest[x];
}
int main()
{
	int T,ans;
	int m,tempa,tempb,afa,bfa;
	scanf("%d",&T);
	while(T--)
	{
		ans=0;
		memset(guest,-1,sizeof(guest));
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&tempa,&tempb);
			afa=findfa(tempa);
			bfa=findfa(tempb);
			if(afa!=bfa)
			{
				guest[bfa]=afa;
			}
		}
		for(int i=1;i<=n;i++)
			if(guest[i]==-1)
				++ans;;
		printf("%d\n",ans);
		
	}
	return 0;
}

畅通工程

跟上一题一模一样。不过我没偷懒重新打了一遍。


More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
问题大意这个是问你最大的并查集的个数。
在并查集中再加入一个cnt,合并的时候需要处理一下。

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAX 10000000+10
using namespace std;
int n;
struct Boy
{
	int fa;
	int cnt;
}boy[MAX];

int findfa(int x)
{
	if(boy[x].fa==-1)
		return x;
	boy[x].fa=findfa(boy[x].fa);
	return boy[x].fa;
}

void merge(int a,int b)
{
	int afa,bfa;
	afa=findfa(a);
	bfa=findfa(b);
	if(afa==bfa)
		return;
	boy[afa].cnt+=boy[bfa].cnt;
	boy[bfa].fa=afa;
	return;
}
void Initial()
{
	for(int i=0;i<MAX;i++)
	{
		boy[i].cnt=1;
		boy[i].fa=-1;
	}
}
int main()
{
	int ans,m,a,b;
	

	while(scanf("%d",&m)!=EOF)
	{
		Initial();
		ans=0;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
		for(int i=1;i<=10000000;i++)
			ans=max(ans,boy[i].cnt);
		printf("%d\n",ans);
	}
	
	return 0;
}

Farm Irrigation

Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

在这里插入图片描述

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

在这里插入图片描述
Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
Output
For each test case, output in one line the least number of wellsprings needed.
Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1
Sample Output
2
3
题目大意就是问你这个二维图里有多少个联通块。可以看看图,蓝色的可以理解为路。
这个题DFS就性,记录下每个块上下左右分别通不通。然后深搜,判断能不能走,这个判断需要动动脑子,具体还是看代码吧。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[60][60];
int mark[60][60];
int n,m;
const int alp[30][5]=//é&#207;óò&#207;&#194;×ó 
{
	{1,0,0,1},{1,1,0,0},{0,0,1,1},{0,1,1,0},{1,0,1,0},{0,1,0,1},{1,1,0,1},{1,0,1,1},{0,1,1,1},{1,1,1,0},{1,1,1,1}
};
const int dir[5][2]={{-1,0},{0,1},{1,0},{0,-1}};
void Initial()
{
	for(int i=0;i<60;i++)
		for(int j=0;j<60;j++)
			map[i][j]=mark[i][j]=0;
}

void DFS(int x,int y,int pip)
{
	mark[x][y]=pip;
	int xx,yy;
	for(int i=0;i<4;i++)
	{
		if(!alp[map[x][y]][i])
			continue;
		xx=x+dir[i][0];
		yy=y+dir[i][1];
		if(xx<0||yy<0||xx>=n||yy>=m||mark[xx][yy])
			continue;
		if(!alp[map[xx][yy]][(i+2)%4])
			continue;
		DFS(xx,yy,pip);
	}
	return;
}

bool read()
{
	scanf("%d%d",&n,&m);
	if(n==-1&&m==-1)
		return 0;
	char str[100];
	for(int i=0;i<n;i++)
	{
		scanf("%s",str);
		for(int j=0;j<m;j++)
			map[i][j]=str[j]-'A';
	}
	return 1;
}
int main()
{
	int pip;
	while(1)
	{
		pip=0;
		Initial();
	
		if(!read())
			break;
	
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
				if(mark[i][j])
					continue;
				else
					DFS(i,j,++pip);
		}

		printf("%d\n",pip);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值